Fedora 19:curl-7.29.0-27.fc19 (2014-16690)

medium Nessus Plugin ID 80337

Synopsis

遠端 Fedora 主機遺漏安全性更新。

描述

- 讓 CURLOPT_LOW_SPEED_LIMIT 可以再次使用執行緒解析器 (#1172572)

- 允許使用 TLS 1.1 和 TLS 1.2 (#1153814)

- 停用 libcurl-level 降級至 SSLv3 (#1166567)

- low-speed-limit:避免逾時溢流 (#1166239)

- 修正 curl_easy_duphandle 中 CURLOPT_COPYPOSTFIELDS 的處理 (CVE-2014-3707)

請注意,Tenable Network Security 已直接從 Fedora 安全性公告擷取前置描述區塊。Tenable 已盡量在不造成其他問題的前提下,嘗試自動清理並將其格式化。

解決方案

更新受影響的 curl 套件。

另請參閱

https://bugzilla.redhat.com/show_bug.cgi?id=1154941

http://www.nessus.org/u?8b2539a5

Plugin 詳細資訊

嚴重性: Medium

ID: 80337

檔案名稱: fedora_2014-16690.nasl

版本: 1.5

類型: local

代理程式: unix

已發布: 2015/1/5

已更新: 2021/1/11

支持的傳感器: Frictionless Assessment Agent, Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 4.2

CVSS v2

風險因素: Medium

基本分數: 4.3

時間分數: 3.7

媒介: AV:N/AC:M/Au:N/C:P/I:N/A:N

時間媒介: E:ND/RL:OF/RC:C

弱點資訊

CPE: p-cpe:/a:fedoraproject:fedora:curl, cpe:/o:fedoraproject:fedora:19

必要的 KB 項目: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2014/12/12

參考資訊

CVE: CVE-2014-3707

BID: 70988

FEDORA: 2014-16690