Oracle Linux 6:libvirt (ELSA-2014-1873)

medium Nessus Plugin ID 79372

Synopsis

遠端 Oracle Linux 主機缺少一個或多個安全性更新。

描述

來自 Red Hat 安全性公告 2014:1873:

現已提供適用於 Red Hat Enterprise Linux 6 的更新版 libvirt 套件,可修正三個安全性問題和一個錯誤。

Red Hat 產品安全性團隊已將此更新評等為具有中等安全性影響。可針對每個弱點從〈參照〉一節的 CVE 連結中取得常見弱點評分系統 (CVSS) 的基本分數,其中包含有關嚴重性評等的詳細資訊。

libvirt 程式庫是用來管理 Linux 和其他作業系統的虛擬化功能並與之互動的 C API。此外,libvirt 還提供遠端管理虛擬化系統的工具。

對持續的磁碟組態編列索引時,在 libvirt 的 qemuDomainGetBlockIoTune() 函式於非持續的 (即時) 磁碟組態中查詢磁碟索引的方法中,發現超出範圍讀取瑕疵。遠端攻擊者若能建立 libvirtd 的唯讀連線,就可利用此瑕疵造成 libvirtd 當機,或可能洩漏 libvirtd 處理程序的記憶體。
(CVE-2014-3633)

在 libvirt virConnectListAllDomains() 函式計算已使用網域數量的方式中發現拒絕服務瑕疵。遠端攻擊者若能建立 libvirtd 的唯讀連線,就可利用此瑕疵造成 libvirtd 中的任何網域作業無回應。(CVE-2014-3657)

據發現,使用 VIR_DOMAIN_XML_MIGRATABLE 旗標時,virDomainGetXMLDesc() 函式的 QEMU 驅動程式實作可繞過 VIR_DOMAIN_XML_SECURE 旗標的限制。遠端攻擊者若能建立 libvirtd 的唯讀連線,就可利用此瑕疵洩漏網域 XML 資料中的某些限制資訊。(CVE-2014-7823)

CVE-2014-3633 問題是由 Red Hat 的 Luyao Huang 所發現。

此更新也可修正下列錯誤:

轉儲存網域中可移轉的 XML 組態時,為與舊版 libvirt 相容,libvirt 會移除某些自動新增的裝置。如果將這種 XML 以移轉時使用的網域 XML 形式傳送給 libvirt,libvirt 會檢查此 XML 是否與網域內部儲存的組態相容。不過在此更新之前,這些檢查都因為缺少裝置 (和 libvirt 移除的裝置相同) 而失敗。因此,將使用者提供的可移轉 XML 進行移轉也會失敗。由於是 OpenStack 使用此功能,因此透過 OpenStack 移轉 QEMU/KVM 網域一律都會失敗。透過此更新,libvirt 在檢查網域組態相容性之前,會先將使用者提供的組態和內部組態轉換成可移轉的形式 (會移除自動新增的裝置),並且改為檢查這些轉換後的組態。因此,無論使用者提供的組態產生時是否為可移轉形式,libvirt 都不會再因缺少裝置而出錯,並且會如預期地順利移轉。(BZ#1155564)

建議所有 libvirt 使用者皆升級至這些更新版套件,其中包含可更正這些問題的反向移植修補程式。安裝更新版套件之後,libvirtd 會自動重新啟動。

解決方案

更新受影響的 libvirt 套件。

另請參閱

https://oss.oracle.com/pipermail/el-errata/2014-November/004655.html

Plugin 詳細資訊

嚴重性: Medium

ID: 79372

檔案名稱: oraclelinux_ELSA-2014-1873.nasl

版本: 1.9

類型: local

代理程式: unix

已發布: 2014/11/21

已更新: 2021/1/14

支持的傳感器: Frictionless Assessment Agent, Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 6

CVSS v2

風險因素: Medium

基本分數: 5.8

時間分數: 5

媒介: AV:N/AC:M/Au:N/C:P/I:N/A:P

時間媒介: E:ND/RL:OF/RC:C

弱點資訊

CPE: p-cpe:/a:oracle:linux:libvirt, p-cpe:/a:oracle:linux:libvirt-client, p-cpe:/a:oracle:linux:libvirt-devel, p-cpe:/a:oracle:linux:libvirt-lock-sanlock, p-cpe:/a:oracle:linux:libvirt-python, cpe:/o:oracle:linux:6

必要的 KB 項目: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2014/11/20

弱點發布日期: 2014/10/6

參考資訊

CVE: CVE-2014-3633, CVE-2014-3657, CVE-2014-7823

BID: 70186, 70210, 71095

RHSA: 2014:1873