Cisco Web Security Appliance Telnet 遠端程式碼執行 (cisco-sa-20120126-ironport)

critical Nessus Plugin ID 79273
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端安全性裝置缺少供應商提供的修補程式。

描述

根據其自我報告的版本,遠端 Cisco Web Security Appliance (WSA) 上執行的 AsyncOS 版本受到一個遠端程式碼執行弱點影響,此弱點是因為 telnet 元件中的一個緩衝區溢位情形所致。

解決方案

套用 Cisco 安全性公告 cisco-sa-20120126-ironpor 中提及的相關更新。

或者因應措施作法是:供應商指出裝置可停用 Telnet 服務。

另請參閱

http://www.nessus.org/u?a6a6592a

https://tools.cisco.com/bugsearch/bug/CSCuo90523

https://www.freebsd.org/security/advisories/FreeBSD-SA-11:08.telnetd.asc

Plugin 詳細資訊

嚴重性: Critical

ID: 79273

檔案名稱: cisco-sa-20120126-wsa.nasl

版本: 1.7

類型: local

系列: CISCO

已發布: 2014/11/17

已更新: 2021/5/14

相依性: cisco_wsa_version.nasl

風險資訊

CVSS 評分資料來源: CVE-2011-4862

VPR

風險因素: Critical

分數: 9

CVSS v2

風險因素: Critical

基本分數: 10

時間分數: 8.7

媒介: AV:N/AC:L/Au:N/C:C/I:C/A:C

時間媒介: E:H/RL:OF/RC:C

弱點資訊

CPE: cpe:/h:cisco:web_security_appliance, cpe:/a:cisco:web_security_appliance, cpe:/o:cisco:web_security_appliance, cpe:/o:cisco:asyncos

必要的 KB 項目: Host/AsyncOS/Cisco Web Security Appliance/DisplayVersion, Host/AsyncOS/Cisco Web Security Appliance/Version

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2014/10/28

弱點發布日期: 2011/12/23

惡意利用途徑

Core Impact

Metasploit (Linux BSD-derived Telnet Service Encryption Key ID Buffer Overflow)

ExploitHub (EH-11-760)

參考資訊

CVE: CVE-2011-4862

BID: 51182

EDB-ID: 18280

CISCO-BUG-ID: CSCuo90523

CISCO-SA: cisco-sa-20120126-ironport