Debian DSA-3069-1:curl - 安全性更新

medium Nessus Plugin ID 79065

Synopsis

遠端 Debian 主機缺少安全性更新。

描述

Symeon Paraschoudis 發現 cURL (一種 URL 傳輸程式庫) 中的 curl_easy_duphandle() 函式有一個錯誤,在執行 HTTP POST 作業時,其可能會導致 libcurl 最後將不應傳送的敏感資料也一併傳送出去。

必須按照該順序使用 CURLOPT_COPYPOSTFIELDS 和 curl_easy_duphandle(),然後再使用複製控制碼執行 HTTP POST,此錯誤才會遭到利用。curl 命令行工具不使用此序列,因此並不會受到此問題的影響。

解決方案

升級 curl 套件。

針對穩定的發行版本 (wheezy),此問題已在 7.26.0-1+wheezy11 版本中修正。

針對即將提供之穩定的發行版本 (jessie),此問題將於 7.38.0-3 版本中修正。

另請參閱

https://packages.debian.org/source/wheezy/curl

https://www.debian.org/security/2014/dsa-3069

Plugin 詳細資訊

嚴重性: Medium

ID: 79065

檔案名稱: debian_DSA-3069.nasl

版本: 1.8

類型: local

代理程式: unix

已發布: 2014/11/10

已更新: 2021/1/11

支持的傳感器: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 4.2

CVSS v2

風險因素: Medium

基本分數: 4.3

時間分數: 3.2

媒介: AV:N/AC:M/Au:N/C:P/I:N/A:N

時間媒介: E:U/RL:OF/RC:C

弱點資訊

CPE: p-cpe:/a:debian:debian_linux:curl, cpe:/o:debian:debian_linux:7.0

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2014/11/7

參考資訊

CVE: CVE-2014-3707

DSA: 3069