PHP 5.6.x < 5.6.2 多個弱點

high Nessus Plugin ID 78547
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Web 伺服器使用受到多個弱點影響的 PHP 版本。

描述

根據遠端主機的標題,其安裝的 PHP 5.6.x 版本比 5.6.2 舊。因此受到以下弱點影響:

- 「mkgmtime」函式中存在一個緩衝區溢位錯誤,可能讓應用程式損毀或執行任意程式碼。(CVE-2014-3668)

- 「unserialize」函式中存在一個整數溢位錯誤,可導致拒絕服務攻擊。
請注意,受此問題影響的只有 32 位元執行個體。
(CVE-2014-3669)

- 「exif_thumbnail」函式中存在一個堆積損毀錯誤,可能讓應用程式損毀或執行任意程式碼。(CVE-2014-3670)

- cURL 延伸模組的「ext/curl/interface.c」檔案和 NULL 選項處理中存在一個輸入驗證錯誤,可導致資訊洩漏。(錯誤 #68089)。

請注意,Nessus 並未嘗試惡意利用這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級為 PHP 5.6.2 或更新版本。

另請參閱

http://www.php.net/ChangeLog-5.php#5.6.2

Plugin 詳細資訊

嚴重性: High

ID: 78547

檔案名稱: php_5_6_2.nasl

版本: 1.9

類型: remote

系列: CGI abuses

已發布: 2014/10/17

已更新: 2021/1/19

相依性: php_version.nasl

風險資訊

CVSS 評分資料來源: CVE-2014-3669

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可輕鬆利用: No exploit is required

修補程式發佈日期: 2014/10/16

弱點發布日期: 2014/10/16

參考資訊

CVE: CVE-2014-3668, CVE-2014-3669, CVE-2014-3670

BID: 70611, 70665, 70666