CentOS 5 / 6 / 7:bash (CESA-2014:1306)

critical Nessus Plugin ID 77879

Synopsis

遠端 CentOS 主機缺少一個或多個安全性更新。

描述

現已提供適用於 Red Hat Enterprise Linux 5、6 和 7 的更新版 bash 套件,可修正一個安全性問題。

Red Hat 產品安全性團隊已將此更新評等為具有重要安全性影響。可從〈參照〉一節的 CVE 連結中取得常見弱點評分系統 (CVSS) 的基本分數,其中包含有關嚴重性評等的詳細資訊。

GNU Bourne Again shell (Bash) 是與 Bourne shell (sh) 相容的 shell 和命令語言解譯器。Bash 是 Red Hat Enterprise Linux 的預設 Shell。

據發現,CVE-2014-6271 的修正不完整,Bash 仍允許透過特製的環境變數將特定字元插入其他環境。攻擊者可能利用此瑕疵覆寫或繞過環境限制,以執行 shell 命令。特定服務和應用程式允許未經驗證的遠端攻擊者提供環境變數,這樣他們便可以惡意利用此問題。
(CVE-2014-7169)

需要讓直接將 bash 函式建立為環境變數的應用程式知道此更新處理名稱方式的變更。如需更多資訊,請參閱此處的知識庫文章:https://access.redhat.com/articles/1200223

注意:建議 Docker 使用者使用其容器內的 'yum update',並提交產生的變更。

如需 CVE-2014-6271 和 CVE-2014-7169 的其他資訊,請參閱上述知識庫文章。

建議所有 bash 使用者皆升級至這些更新版套件,其中包含可修正此問題的反向移植修補程式。

解決方案

更新受影響的 bash 套件。

另請參閱

http://www.nessus.org/u?3e6f3298

http://www.nessus.org/u?7dcec836

http://www.nessus.org/u?d96a66d4

Plugin 詳細資訊

嚴重性: Critical

ID: 77879

檔案名稱: centos_RHSA-2014-1306.nasl

版本: 1.24

類型: local

代理程式: unix

已發布: 2014/9/26

已更新: 2022/1/31

支持的傳感器: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure

風險資訊

VPR

風險因素: High

分數: 8.4

CVSS v2

風險因素: Critical

基本分數: 10

時間分數: 7.8

媒介: AV:N/AC:L/Au:N/C:C/I:C/A:C

時間媒介: E:POC/RL:OF/RC:C

弱點資訊

CPE: p-cpe:/a:centos:centos:bash, p-cpe:/a:centos:centos:bash-doc, cpe:/o:centos:centos:5, cpe:/o:centos:centos:6, cpe:/o:centos:centos:7

必要的 KB 項目: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list, Host/cpu

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2014/9/25

CISA 已知利用日期: 2022/7/28

參考資訊

CVE: CVE-2014-7169, CVE-2014-7186, CVE-2014-7187

BID: 70137, 70152, 70154

RHSA: 2014:1306

IAVA: 2014-A-0142