PHP 5.3.x < 5.3.29 多個弱點

high Nessus Plugin ID 77285
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Web 伺服器使用受到多個弱點影響的 PHP 版本。

描述

根據其標題,遠端主機上安裝的 PHP 版本是比 5.3.29 舊的 5.3.x。因此受到以下弱點影響:

- 與處理 DateInterval 物件相關的檔案 'ext/date/lib/parse_iso_intervals.c' 中存在一個堆積型緩衝區溢位錯誤,可導致拒絕服務攻擊。(CVE-2013-6712)

- 存在一個與 Fileinfo 延伸模組、Composite Document Format (CDF) 處理和函式 'cdf_read_short_sector' 相關的邊界檢查錯誤。(CVE-2014-0207)

- 「src/cdf.c」內的「cdf_unpack_summary_info()」函式中存有瑕疵,處理特製的 CDF 檔案時會發生多個 file_printf 呼叫。
這可導致內容相依的攻擊者使用 PHP 損毀 Web 應用程式。(CVE-2014-0237)

-「src/cdf.c」內的「cdf_read_property_info()」函式中存有瑕疵,處理特製的 CDF 檔案時會發生無限迴圈。這可導致內容相依的攻擊者使用 PHP 損毀 Web 應用程式。(CVE-2014-0238)

- 存在一個與標準 PHP 程式庫 (SPL) 延伸模組和函式「unserialize」相關的類型混淆錯誤。(CVE-2014-3515)

- 存在一個與組態指令碼和暫存檔處理相關的錯誤,可允許不安全的檔案使用方式。(CVE-2014-3981)

- 存在一個與函式「dns_get_record」相關的堆積型緩衝區溢位錯誤,可導致任意程式碼執行。(CVE-2014-4049)

- printf 中存在一個超出邊界讀取問題。(錯誤 #67249)。

請注意,Nessus 並未嘗試惡意利用這些問題,而是僅依據應用程式自我報告的版本號碼。

此外,請注意,版本 5.3.29 標記對 PHP 5.3.x 分支支援的結束。

解決方案

升級為 PHP 5.3.29 或更新版本。

另請參閱

http://php.net/archive/2014.php#id2014-08-14-1

http://www.php.net/ChangeLog-5.php#5.3.29

Plugin 詳細資訊

嚴重性: High

ID: 77285

檔案名稱: php_5_3_29.nasl

版本: 1.10

類型: remote

系列: CGI abuses

已發布: 2014/8/20

已更新: 2021/1/19

相依性: php_version.nasl

風險資訊

CVSS 評分資料來源: CVE-2014-3515

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: High

基本分數: 7.3

時間分數: 6.4

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可輕鬆利用: No exploit is required

修補程式發佈日期: 2014/8/14

弱點發布日期: 2013/11/27

參考資訊

CVE: CVE-2013-6712, CVE-2014-0207, CVE-2014-0237, CVE-2014-0238, CVE-2014-3478, CVE-2014-3479, CVE-2014-3480, CVE-2014-3487, CVE-2014-3515, CVE-2014-3981, CVE-2014-4049, CVE-2014-4721

BID: 64018, 67759, 67765, 67837, 68007, 68120, 68237, 68238, 68239, 68241, 68243, 68423, 69271, 73385