WordPress < 3.7.4 / 3.8.4 / 3.9.2 多個弱點

high Nessus Plugin ID 77157
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Web 伺服器包含一個受多個弱點影響的 PHP 應用程式。

描述

根據其版本號碼,遠端 Web 伺服器上主控的 WordPress 應用程式受到多個弱點影響:

- 在「getid3.lib.php」中存在一個 XML 插入瑕疵,此瑕疵是因為剖析器接受來自未受信任來源的 XML 外部實體所導致。透過使用特製的 XML 資料,遠端攻擊者可存取敏感資訊或造成拒絕服務。這會影響 3.6 到 3.9.1 版 (3.7.4 和 3.8.4 除外)。

- 在「xmlrpc.php」中存在一個 XML 插入瑕疵,此瑕疵是因為剖析器在沒有加以適當驗證的情況下接受 XML 內部實體。透過使用特製的 XML 資料,遠端攻擊者可造成拒絕服務。
這會影響 1.5 到 3.9.1 版 (3.7.4 和 3.8.4 除外)。

- 在處理 widget 時,指令碼「/src/wp-includes/class-wp-customize-widgets.php」中存在一個不安全的序列化瑕疵。這可讓遠端攻擊者執行任意程式碼。3.9 和 3.9.1 版非預設組態會受影響。

- 在構建 CSRF token 時存在一個瑕疵,此瑕疵是因為它未以分隔符號分隔片段,而且沒有以時間常數方式比較 nonce 所導致。這可能允許遠端攻擊者進行暴力密碼破解攻擊,並可能洩漏 CSRF token。這會影響 2.0.3 至 3.9.1 版 (3.7.4 和 3.8.4 版除外)。

- 在「/src/wp-includes/pluggable.php」指令碼內的函式「get_avatar」中存在一個跨網站指令碼瑕疵,其中,來自虛擬人偶的輸入並未在傳回給使用者之前加以驗證。透過使用特製的要求,經驗證的攻擊者可能在瀏覽器/伺服器信任關係中執行任意指令碼。這會影響 3.9.1 版。

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 WordPress 3.7.4 / 3.8.4 / 3.9.2 或更新版本。

另請參閱

https://wordpress.org/news/2014/08/wordpress-3-9-2/

https://codex.wordpress.org/Version_3.9.2

https://seclists.org/oss-sec/2014/q3/301

https://core.trac.wordpress.org/changeset/29405/branches/3.9

https://core.trac.wordpress.org/changeset/29389

https://core.trac.wordpress.org/changeset/29390

https://core.trac.wordpress.org/changeset/29384

https://core.trac.wordpress.org/changeset/29408

https://core.trac.wordpress.org/changeset/29398

Plugin 詳細資訊

嚴重性: High

ID: 77157

檔案名稱: wordpress_3_9_2.nasl

版本: 1.15

類型: remote

系列: CGI abuses

已發布: 2014/8/12

已更新: 2021/1/19

相依性: wordpress_detect.nasl

組態: 啟用 Paranoid 模式

風險資訊

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

弱點資訊

CPE: cpe:/a:wordpress:wordpress

必要的 KB 項目: www/PHP, installed_sw/WordPress, Settings/ParanoidReport

可輕鬆利用: No exploit is required

修補程式發佈日期: 2014/8/6

弱點發布日期: 2014/3/7

參考資訊

CVE: CVE-2014-2053, CVE-2014-5203, CVE-2014-5204, CVE-2014-5205, CVE-2014-5240, CVE-2014-5265, CVE-2014-5266

BID: 69096

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990