CUPS 1.7.x < 1.7.5「get_file」函式符號連結處理資訊洩漏

medium Nessus Plugin ID 77149
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端列印服務可能受到一個資訊洩漏弱點影響。

描述

根據其標題,遠端主機上安裝的 CUPS 版本是比 1.7.5 舊的 1.7.x。因此可能受到 CVE-2014-3537 之修正未完整更正的一個資訊洩漏弱點影響。

「scheduler/client.c」檔案內有關符號連結處理的「get_file」函式中存有瑕疵。這可能允許本機攻擊者造成正常受保護的檔案可以透過 Web 介面存取。

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 CUPS 1.7.5 或更新版本,或是套用供應商修補程式。

另請參閱

https://www.cups.org/blog/2014-07-30-cups-1.7.5.html

https://github.com/apple/cups/issues/4455

https://seclists.org/oss-sec/2014/q3/220

Plugin 詳細資訊

嚴重性: Medium

ID: 77149

檔案名稱: cups_1_7_5.nasl

版本: 1.7

類型: remote

系列: Misc.

已發布: 2014/8/12

已更新: 2019/11/25

相依性: http_version.nasl, cups_1_3_5.nasl

組態: 啟用 Paranoid 模式

風險資訊

CVSS 評分資料來源: CVE-2014-5031

VPR

風險因素: Low

分數: 3.4

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: AV:N/AC:L/Au:N/C:P/I:N/A:N

時間媒介: E:U/RL:OF/RC:C

弱點資訊

CPE: cpe:/a:apple:cups

必要的 KB 項目: www/cups, Settings/ParanoidReport

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2014/7/29

弱點發布日期: 2014/7/22

參考資訊

CVE: CVE-2014-3537, CVE-2014-5029, CVE-2014-5030, CVE-2014-5031

BID: 68788, 68842, 68846, 68847