VMware vCenter Operations Management 套件多個弱點 (VMSA-2014-0007)

high Nessus Plugin ID 76388
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端主機上有一個受到多個弱點影響的虛擬化應用程式。

描述

遠端主機上安裝的 vCenter Operations Manager 版本比 5.8.2 舊。因此受到以下弱點影響:

- 隨附的 Apache Tomcat 版本中,存在一個與處理「Content-Type」HTTP 標頭和 multipart 要求 (如:檔案上傳) 有關的錯誤,這會允許拒絕服務攻擊。(CVE-2014-0050)

- 存在一個安全性繞過錯誤,該錯誤是因為所含的 Apache Struts2 元件所導致;它允許透過 'class' 參數操控 ClassLoader,而該參數會直接對應至 getClass() 方法。未經驗證的遠端攻擊者可利用此問題,操控應用程式伺服器所用的 ClassLoader,進而繞過特定安全性限制。請注意,CVE-2014-0112 之所以存在,是因為 CVE-2014-0094 不是完整的修正。
(CVE-2014-0094、CVE-2014-0112)

解決方案

升級至 vCenter Operations Manager 5.7.3 / 5.8.2 或更新版本。

或者,供應商已針對安全性繞過錯誤提供因應措施。

另請參閱

http://lists.vmware.com/pipermail/security-announce/2014/000257.html

http://www.nessus.org/u?4d46f364

http://www.nessus.org/u?1fe3ac72

http://www.nessus.org/u?be20e92d

Plugin 詳細資訊

嚴重性: High

ID: 76388

檔案名稱: vcenter_operations_manager_vmsa_2014-0007.nasl

版本: 1.8

類型: local

系列: Misc.

已發布: 2014/7/7

已更新: 2018/8/6

相依性: ssh_get_info.nasl

風險資訊

VPR

風險因素: High

分數: 7.4

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 6.2

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:F/RL:OF/RC:C

弱點資訊

CPE: cpe:/a:vmware:vcenter_operations

必要的 KB 項目: Host/VMware vCenter Operations Manager/Version

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2014/6/24

弱點發布日期: 2014/3/25

惡意利用途徑

Core Impact

Metasploit (Apache Struts ClassLoader Manipulation Remote Code Execution)

參考資訊

CVE: CVE-2014-0050, CVE-2014-0094, CVE-2014-0112

BID: 65400, 65999, 67064

VMSA: 2014-0007

IAVB: 2014-B-0090