CentOS 6 : gnutls (CESA-2014:0595)

medium Nessus Plugin ID 74310
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 CentOS 主機缺少一個或多個安全性更新。

描述

現已提供適用於 Red Hat Enterprise Linux 6 的更新版 gnutls 套件,可修正一個安全性問題。

Red Hat 安全性回應團隊已將此更新評等為具有重要安全性影響。可從〈參照〉一節的 CVE 連結中取得常見弱點評分系統 (CVSS) 的基本分數,其中包含有關嚴重性評等的詳細資訊。

GnuTLS 程式庫提供對於加密演算法及諸如傳輸層安全性 (TLS) 等通訊協定的支援。

在 GnuTLS 剖析來自 TLS/SSL 交握 ServerHello 訊息的工作階段 ID 的方式中發現一個瑕疵。惡意伺服器可利用此瑕疵,傳送過長的工作階段 ID 值,進而在使用 GnuTLS 的連線 TLS/SSL 用戶端應用程式中觸發緩衝區溢位,導致用戶端應用程式損毀或可能執行任意程式碼。(CVE-2014-3466)

Red Hat 要感謝 GnuTLS 上游報告此問題。
上游確認 Codenomicon 的 Joonas Kuorilehto 為原始報告者。

建議 GnuTLS 使用者升級至這些更新版套件,以更正此問題。若要使更新生效,所有與 GnuTLS 程式庫連結的應用程式都必須重新啟動。

解決方案

更新受影響的 gnutls 套件。

另請參閱

http://www.nessus.org/u?51a847cc

Plugin 詳細資訊

嚴重性: Medium

ID: 74310

檔案名稱: centos_RHSA-2014-0595.nasl

版本: 1.7

類型: local

代理程式: unix

已發布: 2014/6/5

已更新: 2021/1/4

相依性: ssh_get_info.nasl

風險資訊

CVSS 評分資料來源: CVE-2014-3466

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: Medium

基本分數: 6.8

時間分數: 5.9

媒介: AV:N/AC:M/Au:N/C:P/I:P/A:P

時間媒介: E:ND/RL:OF/RC:C

弱點資訊

CPE: p-cpe:/a:centos:centos:gnutls, p-cpe:/a:centos:centos:gnutls-devel, p-cpe:/a:centos:centos:gnutls-guile, p-cpe:/a:centos:centos:gnutls-utils, cpe:/o:centos:centos:6

必要的 KB 項目: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2014/6/4

弱點發布日期: 2014/6/3

參考資訊

CVE: CVE-2014-3466

BID: 67741

RHSA: 2014:0595