PHP 5.4.x < 5.4.28 FPM Unix 通訊端不安全權限提升

high Nessus Plugin ID 73862
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Web 伺服器使用可能受到權限提升弱點影響的 PHP 版本。

描述

根據其標題,遠端主機上安裝的 PHP 5.4.x 版比 5.4.28 舊。因此可能受到權限提升弱點影響。

設定 Unix 通訊端的權限時 FastCGI Process Manager (FPM) 中存有瑕疵。此瑕疵可導致遠端攻擊者在獲得通訊端存取權後取得提升的權限。

請注意,此外掛程式並未嘗試惡意利用此問題,而是僅依據 PHP 自我報告的版本號碼。

解決方案

升級為 PHP 5.4.28 或更新版本。

另請參閱

http://www.php.net/ChangeLog-5.php#5.4.28

https://bugs.php.net/bug.php?id=67060

http://www.nessus.org/u?a7b8dfdd

Plugin 詳細資訊

嚴重性: High

ID: 73862

檔案名稱: php_5_4_28.nasl

版本: 1.9

類型: remote

系列: CGI abuses

已發布: 2014/5/5

已更新: 2021/1/19

相依性: php_version.nasl

風險資訊

CVSS 評分資料來源: CVE-2014-0185

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: High

基本分數: 7.2

時間分數: 5.3

媒介: AV:L/AC:L/Au:N/C:C/I:C/A:C

時間媒介: E:U/RL:OF/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可輕鬆利用: No exploit is required

修補程式發佈日期: 2014/5/1

弱點發布日期: 2014/4/12

參考資訊

CVE: CVE-2014-0185

BID: 67118