Firefox ESR 24.x < 24.5 多個弱點 (Mac OS X)

critical Nessus Plugin ID 73765

Synopsis

遠端 Mac OS X 主機含有可能受到多個弱點影響的網頁瀏覽器。

描述

安裝的 Firefox ESR 24.x 版比 24.5 舊,因此可能受到下列弱點影響:

- 存有可導致任意程式碼執行的記憶體問題。(CVE-2014-1518、CVE-2014-1519)

- 解碼特定 JPG 影像時存有超出邊界的讀取問題,可引發拒絕服務。(CVE-2014-1523)

- 因 XBL 物件驗證不當而存有記憶體損毀問題,可導致任意程式碼執行。(CVE-2014-1524)

- Web Notification API 中存有安全性繞過問題,可導致任意程式碼執行。
(CVE-2014-1529)

- 存有跨網站指令碼問題,可允許攻擊者載入其他網站,而非位址列中顯示的網站 URL。
(CVE-2014-1530)

- 因 'imgLoader' 物件重新調整大小時被釋放而存有釋放後使用問題。此問題可導致任意程式碼執行。(CVE-2014-1531)

- 主機解析時存有釋放後使用問題,可導致任意程式碼執行。
(CVE-2014-1532)

解決方案

升級至 Firefox ESR 24.5 或更新版本。

另請參閱

https://www.mozilla.org/en-US/security/advisories/mfsa2014-34/

https://www.mozilla.org/en-US/security/advisories/mfsa2014-37/

https://www.mozilla.org/en-US/security/advisories/mfsa2014-38/

https://www.mozilla.org/en-US/security/advisories/mfsa2014-42/

https://www.mozilla.org/en-US/security/advisories/mfsa2014-43/

https://www.mozilla.org/en-US/security/advisories/mfsa2014-44/

http://www.mozilla.org/security/announce/2014/mfsa2014-46.html

Plugin 詳細資訊

嚴重性: Critical

ID: 73765

檔案名稱: macosx_firefox_24_5_esr.nasl

版本: 1.12

類型: local

代理程式: macosx

已發布: 2014/4/29

已更新: 2019/11/26

支持的傳感器: Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: Critical

基本分數: 10

時間分數: 7.4

媒介: AV:N/AC:L/Au:N/C:C/I:C/A:C

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2014-1532

弱點資訊

CPE: cpe:/a:mozilla:firefox_esr

必要的 KB 項目: MacOSX/Firefox/Installed

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2014/4/29

弱點發布日期: 2014/4/29

參考資訊

CVE: CVE-2014-1518, CVE-2014-1519, CVE-2014-1523, CVE-2014-1524, CVE-2014-1529, CVE-2014-1530, CVE-2014-1531, CVE-2014-1532

BID: 67123, 67125, 67129, 67130, 67131, 67134, 67135, 67137

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990