PHP 5.3.x < 5.3.28 多個 OpenSSL 弱點

high Nessus Plugin ID 71426
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Web 伺服器使用可能受到多種弱點影響的 PHP 版本。

描述

根據其標題,遠端主機上安裝的 PHP 版本是比 5.3.28 舊的 5.3.x。因此可能受到以下弱點影響:

- 處理主機名稱中帶有 NULL 位元組的憑證時,PHP OpenSSL 延伸模組的主機名稱身分檢查存有瑕疵。攻擊者可能惡意利用此瑕疵,藉此執行攔截式攻擊,進而偽造 SSL 伺服器。請注意,若要惡意利用此問題,攻擊者需要取得特製的憑證,且該憑證須由用戶端信任的授權單位簽署。(CVE-2013-4073)

- PHP OpenSSL 延伸模組的 openssl_x509_parse() 函式剖析 X.509 憑證的方式存有一個記憶體損毀瑕疵。遠端攻擊者可利用此瑕疵,使用上述函式將自我簽署的惡意憑證或由受信任單位簽署的憑證提供給 PHP 應用程式。這可造成應用程式損毀,或可能導致攻擊者使用執行 PHP 解譯器的使用者權限來執行任意程式碼。(CVE-2013-6420)

請注意,此外掛程式不會嘗試惡意利用這些弱點,而是僅依據 PHP 自我報告的版本號碼。

解決方案

升級為 PHP 5.3.28 或更新版本。

另請參閱

https://seclists.org/fulldisclosure/2013/Dec/96

https://bugzilla.redhat.com/show_bug.cgi?id=1036830

http://www.nessus.org/u?b6ec9ef9

http://www.php.net/ChangeLog-5.php#5.3.28

Plugin 詳細資訊

嚴重性: High

ID: 71426

檔案名稱: php_5_3_28.nasl

版本: 1.17

類型: remote

系列: CGI abuses

已發布: 2013/12/14

已更新: 2021/1/19

相依性: php_version.nasl

風險資訊

CVSS 評分資料來源: CVE-2013-6420

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.9

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:POC/RL:OF/RC:C

CVSS v3

風險因素: High

基本分數: 7.3

時間分數: 6.6

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

時間媒介: E:P/RL:O/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可被惡意程式利用: true

可輕鬆利用: No exploit is required

修補程式發佈日期: 2013/12/12

弱點發布日期: 2013/6/27

參考資訊

CVE: CVE-2013-4073, CVE-2013-4248, CVE-2013-6420

BID: 60843, 61776, 64225

EDB-ID: 30395