Oracle Linux 6:rubygems (ELSA-2013-1441)

medium Nessus Plugin ID 70524

Synopsis

遠端 Oracle Linux 主機缺少一個安全性更新。

描述

來自 Red Hat 安全性公告 2013:1441:

現已提供適用於 Red Hat Enterprise Linux 6 的更新版 rubygems 套件,可修正三個安全性問題。

Red Hat 安全性回應團隊已將此更新評等為具有中等安全性影響。可針對每個弱點從〈參照〉一節的 CVE 連結中取得常見弱點評分系統 (CVSS) 的基本分數,其中包含有關嚴重性評等的詳細資訊。

RubyGems 是 Ruby 用於發佈和管理第三方程式庫的標準。

發現 RubyGems 未驗證 SSL 連線。此問題可導致攔截式攻擊。(CVE-2012-2126)

據發現,在使用 RubyGems 時,連線可從 HTTPS 重新導向至 HTTP。這可讓使用者以為自己是透過 HTTPS 安裝 gem,但實際上連線安全等級已悄悄降為 HTTP。(CVE-2012-2125)

據發現,rubygems API 會使用不安全的規則運算式驗證版本字串。如果應用程式利用此 API 處理來自未受信任之來源的版本字串,就可遭到攻擊者透過 CPU 耗盡引發的拒絕服務攻擊。
(CVE-2013-4287)

Red Hat 要感謝 Rubygems 上游報告 CVE-2013-4287。上游確認 Damir Sharipov 為原始報告者。

建議所有 rubygems 使用者皆升級至此更新版套件,其中含有可更正這些問題的反向移植修補程式。

解決方案

更新受影響的 rubygems 套件。

另請參閱

https://oss.oracle.com/pipermail/el-errata/2013-October/003734.html

Plugin 詳細資訊

嚴重性: Medium

ID: 70524

檔案名稱: oraclelinux_ELSA-2013-1441.nasl

版本: 1.8

類型: local

代理程式: unix

已發布: 2013/10/20

已更新: 2021/1/14

支持的傳感器: Frictionless Assessment Agent, Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 4.7

CVSS v2

風險因素: Medium

基本分數: 5.8

時間分數: 4.3

媒介: AV:N/AC:M/Au:N/C:P/I:P/A:N

時間媒介: E:U/RL:OF/RC:C

弱點資訊

CPE: p-cpe:/a:oracle:linux:rubygems, cpe:/o:oracle:linux:6

必要的 KB 項目: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2013/10/18

弱點發布日期: 2013/10/1

參考資訊

CVE: CVE-2012-2125, CVE-2012-2126, CVE-2013-4287

BID: 53174, 55680, 62281, 62442

RHSA: 2013:1441