Debian DSA-2766-1 : linux-2.6 - 權限提升/拒絕服務/資訊洩漏

medium Nessus Plugin ID 70200
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Debian 主機缺少安全性更新。

描述

在 Linux 核心中發現數個弱點,可能會導致拒絕服務、資訊洩漏或權限提升。Common Vulnerabilities and Exposures 專案發現下列問題:

- CVE-2013-2141 Emese Revfy 針對 tkill 和 tgkill 系統呼叫中的資訊洩漏提供修正。64 位元系統上的本機使用者可取得敏感記憶體內容的存取權。

- CVE-2013-2164 Jonathan Salwan 報告 CD-ROM 驅動程式中有一個資訊洩漏瑕疵。如果系統內有運作失常的 CD-ROM 磁碟機,則該系統上的本機使用者可取得敏感記憶體的存取權。

- CVE-2013-2206 Karl Heiss 報告 Linux SCTP 實作中存在一個問題。遠端使用者可造成拒絕服務 (系統當機)。

- CVE-2013-2232 Dave Jones 和 Hannes Frederic Sowa 已解決 IPv6 子系統中的一個問題。本機使用者可使用 AF_INET6 通訊端連線至 IPv4 目的地,從而引發拒絕服務。

- CVE-2013-2234 Mathias Krause 報告,在 PF_KEYv2 通訊端實作中有一個記憶體洩漏瑕疵。本機使用者可取得敏感核心記憶體的存取權。

- CVE-2013-2237 Nicolas Dichtel 報告,在 PF_KEYv2 通訊端實作中有一個記憶體洩漏瑕疵。本機使用者可取得敏感核心記憶體的存取權。

- CVE-2013-2239 Jonathan Salwan 在 openvz 核心類別中發現多個記憶體洩漏。本機使用者可取得敏感核心記憶體的存取權。

- CVE-2013-2851 Kees Cook 報告封鎖子系統中的問題。
具有 uid 0 的本機使用者可取得提升的第 0 級權限。這是某些經過特別設定的系統才會出現的安全性問題。

- CVE-2013-2852 Kees Cook 報告,特定 Broadcom 無線裝置的 b43 網路驅動程式中有一個問題。具有 uid 0 的本機使用者可取得提升的第 0 級權限。這是某些經過特別設定的系統才會出現的安全性問題。

- CVE-2013-2888 Kees Cook 報告 HID 驅動程式子系統中存在一個問題。
能夠附加裝置的本機使用者可造成拒絕服務 (系統當機)。

- CVE-2013-2892 Kees Cook 報告 pantherlord HID 裝置驅動程式中存在一個問題。能夠附加裝置的本機使用者可造成拒絕服務或可能取得提升的權限。

解決方案

升級 linux-2.6 和 user-mode-linux 套件。

針對舊的穩定發行版本 (squeeze),此問題已在 2.6.32-48squeeze4 版中修正。

下列矩陣列出了為與此更新相容或利用此更新所重建的其他來源套件:

  Debian 6.0 (squeeze) user-mode-linux 2.6.32-1um-4+48squeeze4 注意:在啟用安全性支援的情況下,Debian 會謹慎追蹤所有版本中每個 linux 核心套件的所有已知安全性問題。
但鑒於發現核心中低嚴重性安全問題的高頻率和進行更新的資源需求,通常不會同時針對所有核心發佈解決較低優先順序問題的更新。反而會以交錯或「跳位」的方式發佈更新。

另請參閱

https://security-tracker.debian.org/tracker/CVE-2013-2141

https://security-tracker.debian.org/tracker/CVE-2013-2164

https://security-tracker.debian.org/tracker/CVE-2013-2206

https://security-tracker.debian.org/tracker/CVE-2013-2232

https://security-tracker.debian.org/tracker/CVE-2013-2234

https://security-tracker.debian.org/tracker/CVE-2013-2237

https://security-tracker.debian.org/tracker/CVE-2013-2239

https://security-tracker.debian.org/tracker/CVE-2013-2851

https://security-tracker.debian.org/tracker/CVE-2013-2852

https://security-tracker.debian.org/tracker/CVE-2013-2888

https://security-tracker.debian.org/tracker/CVE-2013-2892

https://packages.debian.org/source/squeeze/linux-2.6

https://www.debian.org/security/2013/dsa-2766

Plugin 詳細資訊

嚴重性: Medium

ID: 70200

檔案名稱: debian_DSA-2766.nasl

版本: 1.14

類型: local

代理程式: unix

已發布: 2013/9/30

已更新: 2021/1/11

相依性: ssh_get_info.nasl

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: Medium

基本分數: 6.9

時間分數: 5.4

媒介: AV:L/AC:M/Au:N/C:C/I:C/A:C

時間媒介: E:POC/RL:OF/RC:C

弱點資訊

CPE: p-cpe:/a:debian:debian_linux:linux-2.6, cpe:/o:debian:debian_linux:6.0

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2013/9/27

弱點發布日期: 2013/6/7

參考資訊

CVE: CVE-2013-2141, CVE-2013-2164, CVE-2013-2206, CVE-2013-2232, CVE-2013-2234, CVE-2013-2237, CVE-2013-2239, CVE-2013-2851, CVE-2013-2852, CVE-2013-2888, CVE-2013-2892

BID: 60254, 60375, 60409, 60410, 60715, 60874, 60893, 60953, 60977, 62043, 62049

DSA: 2766