Debian DSA-2738-1 : ruby1.9.1 - 數個弱點

medium Nessus Plugin ID 69398

Synopsis

遠端 Debian 主機缺少安全性更新。

描述

在 Ruby 語言的解譯器中發現數個弱點,可能導致拒絕服務和其他安全性問題。Common Vulnerabilities and Exposures 專案發現下列問題:

- CVE-2013-1821 Ben Murphy 發現 REXML 中有不受限制的實體擴充,可能會導致占用所有主機記憶體,從而引發拒絕服務。

- CVE-2013-4073 William (B.J.)Snow Orvis 在 Ruby 之 SSL 用戶端的主機名稱檢查中發現一個弱點,該弱點可允許攔截式攻擊者透過受信任之憑證授權單位所核發的有效憑證,偽造 SSL 伺服器。

解決方案

升級 ruby1.9.1 套件。

針對舊的穩定發行版本 (squeeze),這些問題已在 1.9.2.0-2+deb6u1 版本中修正。

針對穩定的發行版本 (wheezy),這些問題已在 1.9.3.194-8.1+deb7u1 版本中修正。

另請參閱

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=702525

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=714543

https://security-tracker.debian.org/tracker/CVE-2013-1821

https://security-tracker.debian.org/tracker/CVE-2013-4073

https://packages.debian.org/source/wheezy/ruby1.9.1

https://www.debian.org/security/2013/dsa-2738

Plugin 詳細資訊

嚴重性: Medium

ID: 69398

檔案名稱: debian_DSA-2738.nasl

版本: 1.12

類型: local

代理程式: unix

已發布: 2013/8/20

已更新: 2021/1/11

支持的傳感器: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: Medium

基本分數: 6.8

時間分數: 5

媒介: AV:N/AC:M/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

弱點資訊

CPE: p-cpe:/a:debian:debian_linux:ruby1.9.1, cpe:/o:debian:debian_linux:6.0, cpe:/o:debian:debian_linux:7.0

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2013/8/18

參考資訊

CVE: CVE-2013-1821, CVE-2013-4073

BID: 58141, 60843

DSA: 2738