Oracle Linux 6:核心 (ELSA-2013-0911)

high Nessus Plugin ID 68834

Synopsis

遠端 Oracle Linux 主機缺少一個或多個安全性更新。

描述

遠端 Oracle Linux 6 主機中安裝的套件受到 ELSA-2013-0911 公告中提及的多個弱點影響。

- Red Hat Enterprise Linux (RHEL) 6 上 2.6.32-358.11.1.el6 版之前的核心套件中,KVM 子系統的特定 Red Hat 修補程式不會正確實作 PV EOI 功能,這會允許來賓 OS 使用者藉由利用時間範圍 (在此期間中斷功能遭到停用,但可以發出 copy_to_user 函式呼叫),引致拒絕服務 (主機 OS 當機)。(CVE-2013-1935)

- 在 3.0 版之前的 Linux 核心中,KVM 子系統在配置記憶體插槽以給來賓實體位址空間使用時,不會檢查是否已指定核心位址,這會允許本機使用者透過特製的應用程式,從核心記憶體取得特權或敏感資訊,而這其實與 arch/x86/kvm/paging_tmpl.h 和 virt/kvm/kvm_main.c 相關。(CVE-2013-1943)

- 在 2.6.34 版之前的 Linux 核心中,veth (亦稱「虛擬乙太網路」) 驅動程式在壅塞期間不會正確管理 skbs,這會允許遠端攻擊者利用缺少 skb 消耗並搭配雙重釋放錯誤,進而引致拒絕服務 (系統當機)。(CVE-2013-2017)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

更新受影響的套件。

另請參閱

https://linux.oracle.com/errata/ELSA-2013-0911.html

Plugin 詳細資訊

嚴重性: High

ID: 68834

檔案名稱: oraclelinux_ELSA-2013-0911.nasl

版本: 1.17

類型: local

代理程式: unix

已發布: 2013/7/12

已更新: 2021/9/8

支持的傳感器: Frictionless Assessment Agent, Nessus Agent

風險資訊

CVSS 評分資料來源: CVE-2013-1943

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: High

基本分數: 7.8

時間分數: 5.8

媒介: AV:N/AC:L/Au:N/C:N/I:N/A:C

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: High

基本分數: 7.8

時間分數: 6.8

媒介: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/o:oracle:linux:6, p-cpe:/a:oracle:linux:kernel, p-cpe:/a:oracle:linux:kernel-debug, p-cpe:/a:oracle:linux:kernel-debug-devel, p-cpe:/a:oracle:linux:kernel-devel, p-cpe:/a:oracle:linux:kernel-firmware, p-cpe:/a:oracle:linux:kernel-headers, p-cpe:/a:oracle:linux:perf, p-cpe:/a:oracle:linux:python-perf

必要的 KB 項目: Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list, Host/local_checks_enabled

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2013/6/11

弱點發布日期: 2013/4/29

參考資訊

CVE: CVE-2013-1935, CVE-2013-1943, CVE-2013-2017, CVE-2013-2188

BID: 59549, 59846, 60463, 60466, 61195

RHSA: 2013:0911