Oracle Linux 5︰hypervkvpd (ELSA-2013-0807)

medium Nessus Plugin ID 68818

Synopsis

遠端 Oracle Linux 主機缺少一個安全性更新。

描述

來自 Red Hat 安全性公告 2013:0807:

現已提供適用於 Red Hat Enterprise Linux 5 的更新版 hypervkvpd 套件,可修正一個安全性問題和一個錯誤。

Red Hat 安全性回應團隊已將此更新評等為具有低安全性影響。可從〈參照〉一節的 CVE 連結中取得常見弱點評分系統 (CVSS) 的基本分數,其中包含有關嚴重性評等的詳細資訊。

hypervkvpd 套件包含 hypervkvpd,也就是來賓 Microsoft Hyper-V Key-Value Pair (KVP) 程序。此程序會透過 VMBus,將基本資訊 (例如來賓 IP 位址、完整網域名稱、作業系統名稱,以及作業系統版本編號) 傳遞至主機。

在 hypervkvpd 處理某些 Netlink 訊息的方式中發現拒絕服務瑕疵。在來賓 (在 Microsoft Hyper-V 上執行) 中,無權限的本機使用者可在處理 Netlink 訊息時傳送該訊息,這會使該來賓的 hypervkvpd 程序結束。
(CVE-2012-5532)

CVE-2012-5532 問題是由 Red Hat 產品安全性團隊的 Florian Weimer 所發現。

此更新也可修正下列錯誤:

* hypervkvpd 程序不會關閉更新時集區檔案的檔案描述符號。這最終可能會導致 hypervkvpd 在消耗所有可用的檔案描述符號後損毀,並且出現「KVP:無法開啟檔案,集區: 1」的錯誤訊息。透過此更新,可以關閉檔案描述符號,從而更正此問題。(BZ#953502)

建議 hypervkvpd 使用者升級至此更新版套件,其中包含可更正這些問題的反向移植修補程式。安裝更新之後,建議為所有來賓機器重新開機。

解決方案

更新受影響的 hypervkvpd 套件。

另請參閱

https://oss.oracle.com/pipermail/el-errata/2013-May/003457.html

Plugin 詳細資訊

嚴重性: Medium

ID: 68818

檔案名稱: oraclelinux_ELSA-2013-0807.nasl

版本: 1.6

類型: local

代理程式: unix

已發布: 2013/7/12

已更新: 2021/1/14

支持的傳感器: Frictionless Assessment Agent, Nessus Agent

風險資訊

VPR

風險因素: Low

分數: 3.6

CVSS v2

風險因素: Medium

基本分數: 4.9

時間分數: 3.6

媒介: AV:L/AC:L/Au:N/C:N/I:N/A:C

時間媒介: E:U/RL:OF/RC:C

弱點資訊

CPE: p-cpe:/a:oracle:linux:hypervkvpd, cpe:/o:oracle:linux:5

必要的 KB 項目: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2013/5/10

弱點發布日期: 2012/12/27

參考資訊

CVE: CVE-2012-5532

BID: 56710

RHSA: 2013:0807