Oracle Linux 5 / 6:expat (ELSA-2012-0731)

medium Nessus Plugin ID 68543
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Oracle Linux 主機缺少一個或多個安全性更新。

描述

來自 Red Hat 安全性公告 2012:0731:

現已提供適用於 Red Hat Enterprise Linux 5 和 6 的更新版 expat 套件,可修正兩個安全性問題。

Red Hat 安全性回應團隊已將此更新評等為具有中等安全性影響。可針對每個弱點從〈參照〉一節的 CVE 連結中取得常見弱點評分系統 (CVSS) 的基本分數,其中包含有關嚴重性評等的詳細資訊。

Expat 是 James Clark 為了剖析 XML 文件所編寫的一種 C 程式庫。

在 Expat 的雜湊陣列實作中,發現一個拒絕服務瑕疵。攻擊者可利用此瑕疵,藉由提供特製的 XML 檔案來觸發多個雜湊函式衝突,進而讓使用 Expat 的應用程式消耗過多 CPU 時間。為了減輕此問題,已將隨機化加入雜湊函式,以降低攻擊者成功引發有意衝突的機會。(CVE-2012-0876)

在 Expat 中發現一個記憶體洩漏瑕疵。當連結至 Expat 的應用程式所處理的 XML 檔案觸發了記憶體重新配置失敗,Expat 就無法釋放先前配置的記憶體。此問題可導致應用程式意外結束,或在所有可用記憶體用完時發生損毀。(CVE-2012-1148)

所有 Expat 使用者皆應升級至這些更新版套件,其中包含可更正這些問題的反向移植修補程式。安裝更新套件之後,使用 Expat 程式庫的應用程式必須重新啟動,更新才會生效。

解決方案

更新受影響的 expat 套件。

另請參閱

https://oss.oracle.com/pipermail/el-errata/2012-June/002859.html

https://oss.oracle.com/pipermail/el-errata/2012-June/002861.html

Plugin 詳細資訊

嚴重性: Medium

ID: 68543

檔案名稱: oraclelinux_ELSA-2012-0731.nasl

版本: 1.12

類型: local

代理程式: unix

已發布: 2013/7/12

已更新: 2021/1/14

相依性: ssh_get_info.nasl

風險資訊

VPR

風險因素: Low

分數: 3.6

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: AV:N/AC:L/Au:N/C:N/I:N/A:P

時間媒介: E:U/RL:OF/RC:C

弱點資訊

CPE: p-cpe:/a:oracle:linux:expat, p-cpe:/a:oracle:linux:expat-devel, cpe:/o:oracle:linux:5, cpe:/o:oracle:linux:6

必要的 KB 項目: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2012/6/14

弱點發布日期: 2012/7/3

參考資訊

CVE: CVE-2012-0876, CVE-2012-1148

BID: 52379

RHSA: 2012:0731