Oracle Linux 4 / 5 : nss (ELSA-2010-0165)

medium Nessus Plugin ID 68019
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Oracle Linux 主機缺少一個或多個安全性更新。

描述

來自 Red Hat 安全性公告 2010:0165:

現已提供適用於 Red Hat Enterprise Linux 4 和 5 的更新版 nss 套件,以修正一個安全性問題。

Red Hat 安全性回應團隊已將此更新評等為具有中等安全性影響。可從〈參照〉一節的 CVE 連結中取得常見弱點評分系統 (CVSS) 的基本分數,其中包含有關嚴重性評等的詳細資訊。

Network Security Services (NSS) 是一組程式庫,專用於支援啟用安全性之用戶端及伺服器應用程式的跨平台開發。內建 NSS 的應用程式可支援 SSLv2、 SSLv3、TLS 和其他安全性標準。

Netscape Portable Runtime (NSPR) 為非圖形使用者介面 (GUI) 作業系統機能提供平台獨立性。這些機能包含執行緒、執行緒同步、一般檔案與網路 I/O、間隔時序、行事曆時間、基本記憶體管理 (malloc 與 free) 和共用程式庫連結。

在傳輸層安全性/安全通訊端層 (Transport Layer Security/Secure Sockets Layer, TLS/SSL) 通訊協定處理工作階段重新交涉的方式中發現一個瑕疵。攔截式攻擊者可利用此瑕疵將任意純文字前置至用戶端工作階段 (例如,HTTPS 連線至網站)。如此可強制伺服器處理攻擊者的要求 (偽裝成受害者的認證身分完成驗證)。此更新透過 RFC 5746 中所定義的 TLS 重新交涉指示延伸 (Renegotiation Indication Extension) 模組來解決該瑕疵。
(CVE-2009-3555)

如需關於此瑕疵的其他詳細資訊,請參閱下列知識庫文章:http://kbase.redhat.com/faq/docs/DOC-20491

Red Hat Certificate System 7.3 和 8.0 的使用者應在安裝此更新前,先參閱下列知識庫文章:
http://kbase.redhat.com/faq/docs/DOC-28439

建議所有 NSS 使用者皆升級至這些更新版套件,其可將 NSS 更新至 3.12.6 版。此錯字勘誤表亦會將 NSPR 套件更新至 NSS 3.12.6 所要求的版本。所有使用 NSS 程式庫的執行中應用程式皆須重新啟動,更新才會生效。

解決方案

更新受影響的 nss 套件。

另請參閱

https://oss.oracle.com/pipermail/el-errata/2010-March/001402.html

https://oss.oracle.com/pipermail/el-errata/2010-March/001411.html

Plugin 詳細資訊

嚴重性: Medium

ID: 68019

檔案名稱: oraclelinux_ELSA-2010-0165.nasl

版本: 1.10

類型: local

代理程式: unix

已發布: 2013/7/12

已更新: 2021/1/14

相依性: ssh_get_info.nasl

風險資訊

VPR

風險因素: Low

分數: 3.3

CVSS v2

風險因素: Medium

基本分數: 5.8

時間分數: 4.5

媒介: AV:N/AC:M/Au:N/C:N/I:P/A:P

時間媒介: E:POC/RL:OF/RC:C

弱點資訊

CPE: p-cpe:/a:oracle:linux:nspr, p-cpe:/a:oracle:linux:nspr-devel, p-cpe:/a:oracle:linux:nss, p-cpe:/a:oracle:linux:nss-devel, p-cpe:/a:oracle:linux:nss-pkcs11-devel, p-cpe:/a:oracle:linux:nss-tools, cpe:/o:oracle:linux:4, cpe:/o:oracle:linux:5

必要的 KB 項目: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2010/3/26

弱點發布日期: 2009/11/9

參考資訊

CVE: CVE-2009-3555

RHSA: 2010:0165

CWE: 310