Oracle Linux 3 / 4 / 5 : cups (ELSA-2008-0937)

critical Nessus Plugin ID 67755
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Oracle Linux 主機缺少一個或多個安全性更新。

描述

來自 Red Hat 安全性公告 2008:0937:

現已提供適用於 Red Hat Enterprise Linux 3、4 和 5 的更新版 cups 套件,可修正多個安全性問題。

Red Hat 安全性回應團隊已將此更新評等為具有重要安全性影響。

公共 UNIX 列印系統 (CUPS) 為 UNIX(R) 作業系統提供可攜式列印層。

在 CUPS 影像轉換篩選器「imagetops」所使用的 SGI 影像格式解碼常式中發現一個緩衝區溢位瑕疵。攻擊者可建立惡意 SGI 影像檔案,當列印該檔案時,其可能會以「lp」使用者身分執行任意程式碼。
(CVE-2008-3639)

在 Text-to-PostScript「texttops」篩選器中發現一個導致堆積緩衝區溢位的整數溢位瑕疵。攻擊者可建立惡意文字檔案,當列印該檔案時,其可能會以「lp」使用者身分執行任意程式碼。
(CVE-2008-3640)

在 HP-GL/2-to-PostScript「hpgltops」篩選器中發現一個不充分緩衝區邊界檢查瑕疵。攻擊者可建立惡意 HP-GL/2 檔案,當列印該檔案時,其可能會以「lp」使用者身分執行任意程式碼。(CVE-2008-3641)

Red Hat 要感謝 regenrecht 報告這些問題。

建議所有 CUPS 使用者皆升級至這些更新版套件,其中含有可解決這些問題的反向移植修補程式。

解決方案

更新受影響的 cups 套件。

另請參閱

https://oss.oracle.com/pipermail/el-errata/2008-October/000759.html

https://oss.oracle.com/pipermail/el-errata/2008-October/000760.html

https://oss.oracle.com/pipermail/el-errata/2008-October/000761.html

Plugin 詳細資訊

嚴重性: Critical

ID: 67755

檔案名稱: oraclelinux_ELSA-2008-0937.nasl

版本: 1.10

類型: local

代理程式: unix

已發布: 2013/7/12

已更新: 2021/1/14

相依性: ssh_get_info.nasl

風險資訊

VPR

風險因素: High

分數: 7.4

CVSS v2

風險因素: Critical

基本分數: 10

媒介: AV:N/AC:L/Au:N/C:C/I:C/A:C

弱點資訊

CPE: p-cpe:/a:oracle:linux:cups, p-cpe:/a:oracle:linux:cups-devel, p-cpe:/a:oracle:linux:cups-libs, p-cpe:/a:oracle:linux:cups-lpd, cpe:/o:oracle:linux:3, cpe:/o:oracle:linux:4, cpe:/o:oracle:linux:5

必要的 KB 項目: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2008/10/10

弱點發布日期: 2008/10/10

惡意利用途徑

Core Impact

參考資訊

CVE: CVE-2008-3639, CVE-2008-3640, CVE-2008-3641, CVE-2009-0577

RHSA: 2008:0937

CWE: 119, 189, 399