PHP 5.3.x < 5.3.27 多個弱點

medium Nessus Plugin ID 67259

Synopsis

遠端 Web 伺服器使用可能受到多種弱點影響的 PHP 版本。

描述

根據遠端主機的標題,其安裝的 PHP 5.3.x 版本比 5.3.27 舊。因此可能受到以下弱點影響:

- 函式「_pdo_pgsql_error」中存在緩衝區溢位錯誤。(錯誤 #64949)

- 檔案「ext/xml/xml.c」的數個函式中存在堆積損毀錯誤。(CVE-2013-4113/錯誤 #65236)

請注意,此外掛程式不會嘗試惡意利用這些弱點,而是僅依據 PHP 自我報告的版本號碼。

解決方案

套用廠商修補程式或升級至 PHP 5.3.27 或更新版本。

另請參閱

https://bugs.php.net/bug.php?id=64949

https://bugs.php.net/bug.php?id=65236

http://www.php.net/ChangeLog-5.php#5.3.27

Plugin 詳細資訊

嚴重性: Medium

ID: 67259

檔案名稱: php_5_3_27.nasl

版本: 1.20

類型: remote

系列: CGI abuses

已發布: 2013/7/12

已更新: 2022/4/11

組態: 啟用徹底檢查

風險資訊

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: Medium

基本分數: 6.8

時間分數: 5

媒介: AV:N/AC:M/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2013-4113

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可輕鬆利用: No exploit is required

修補程式發佈日期: 2013/7/11

弱點發布日期: 2013/7/4

參考資訊

CVE: CVE-2013-4113

BID: 61128