CentOS 4 : php (CESA-2007:0349)

high Nessus Plugin ID 67050
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 CentOS 主機缺少一個或多個安全性更新。

描述

現已提供適用於 Red Hat Enterprise Linux 4 的更新版 PHP 套件,可修正兩個安全性問題。

Red Hat 安全性回應團隊已將此更新評等為具有重要安全性影響。

PHP 是一種內嵌 HTML 的指令碼語言,通常用於 Apache HTTP Web 伺服器。

在 PHP 的 'xmlrpc' 延伸模組中發現一個堆積緩衝區溢位瑕疵。使用此延伸模組並實作 XML-RPC 伺服器的 PHP 指令碼,可允許遠端攻擊者以 'apache' 使用者的身分,執行任意程式碼。請注意,此瑕疵不會影響使用 pure-PHP XML_RPC 類別 (/usr/share/pear 中所提供之類別) 的 PHP 應用程式。
(CVE-2007-1864)

在 PHP「ftp」延伸模組中發現一個瑕疵。如果 PHP 指令碼使用此延伸模組提供對於私人 FTP 伺服器的存取權,並將不受信任的指令碼輸入直接傳送給此延伸模組所提供的任何函式,遠端攻擊者便能夠傳送任意 FTP 命令給該伺服器。(CVE-2007-2509)

PHP 使用者應升級至這些更新版套件,其中包含可更正這些問題的反向移植修補程式。

解決方案

更新受影響的 php 套件。

另請參閱

http://www.nessus.org/u?7476d121

Plugin 詳細資訊

嚴重性: High

ID: 67050

檔案名稱: centos_RHSA-2007-0349.nasl

版本: 1.8

類型: local

代理程式: unix

已發布: 2013/6/29

已更新: 2021/1/4

相依性: ssh_get_info.nasl

風險資訊

VPR

風險因素: Medium

分數: 5.8

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 6.5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:ND/RL:OF/RC:C

弱點資訊

CPE: p-cpe:/a:centos:centos:php, p-cpe:/a:centos:centos:php-devel, p-cpe:/a:centos:centos:php-domxml, p-cpe:/a:centos:centos:php-gd, p-cpe:/a:centos:centos:php-imap, p-cpe:/a:centos:centos:php-ldap, p-cpe:/a:centos:centos:php-mbstring, p-cpe:/a:centos:centos:php-mysql, p-cpe:/a:centos:centos:php-ncurses, p-cpe:/a:centos:centos:php-odbc, p-cpe:/a:centos:centos:php-pear, p-cpe:/a:centos:centos:php-pgsql, p-cpe:/a:centos:centos:php-snmp, p-cpe:/a:centos:centos:php-xmlrpc, cpe:/o:centos:centos:4

必要的 KB 項目: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2007/5/9

弱點發布日期: 2007/5/8

參考資訊

CVE: CVE-2007-1864, CVE-2007-2509

BID: 23813

RHSA: 2007:0349

CWE: 20, 119