Debian DSA-2661-1:xorg-server - 資訊洩漏

low Nessus Plugin ID 66004

Synopsis

遠端 Debian 主機缺少安全性更新。

描述

Red Hat 的 David Airlie 和 Peter Hutterer 發現,X.Org X 伺服器 xorg-server 容易受到一個與輸入處理和裝置熱插拔有關的資訊洩漏瑕疵影響。

當 X 伺服器執行中但不是在前端 (例如因為 VT 交換器),X 伺服器仍會識別和處理新插入的輸入裝置,而實際上會將輸入事件傳輸至其後端的用戶端。

這可允許攻擊者復原部分非預定用於 X 用戶端的輸入事件,包括敏感資訊。

解決方案

升級 xorg-server 套件。

針對穩定的發行版本 (squeeze),此問題已在 2:1.7.7-16 版中修正。

另請參閱

https://packages.debian.org/source/squeeze/xorg-server

https://www.debian.org/security/2013/dsa-2661

Plugin 詳細資訊

嚴重性: Low

ID: 66004

檔案名稱: debian_DSA-2661.nasl

版本: 1.7

類型: local

代理程式: unix

已發布: 2013/4/18

已更新: 2021/1/11

支持的傳感器: Frictionless Assessment Agent, Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 4.2

CVSS v2

風險因素: Low

基本分數: 2.1

媒介: AV:L/AC:L/Au:N/C:P/I:N/A:N

弱點資訊

CPE: p-cpe:/a:debian:debian_linux:xorg-server, cpe:/o:debian:debian_linux:6.0

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

修補程式發佈日期: 2013/4/17

參考資訊

CVE: CVE-2013-1940

DSA: 2661