CentOS 5 : 核心 (CESA-2013:0621)

medium Nessus Plugin ID 65224

Synopsis

遠端 CentOS 主機缺少一個或多個安全性更新。

描述

現已提供適用於 Red Hat Enterprise Linux 5 的更新版核心套件,可修正兩個安全性問題。

Red Hat 安全性回應團隊已將此更新評等為具有重要安全性影響。可從〈參照〉一節的 CVE 連結中取得常見弱點評分系統 (CVSS) 的基本分數,其中包含有關嚴重性評等的詳細資訊。

kernel 套件中包含 Linux 核心,這是任何 Linux 作業系統的核心。

此更新可修正下列安全性問題:

* 在受限的 root 環境下執行‘/dev/cpu/[x]/msr’檔案的檔案權限檢查方式 (例如,使用以功能為基礎的安全性模型) 中發現一個瑕疵。能夠寫入這些檔案的本機使用者可利用此瑕疵將其權限提升為核心層級,例如,透過寫入 SYSENTER_EIP_MSR 暫存器的方式。(CVE-2013-0268,重要)

* Linux 核心的 ptrace 實作在除錯項目因為 SIGKILL 訊號而變得活躍 (而非遭到停止) 時處理 PTRACE_SETREGS 要求的方式中發現爭用情形。無權限的本機使用者可利用此瑕疵提升自己的權限。
(CVE-2013-0871,重要)

使用者應升級至這些更新版套件,其中包含可更正這些問題的反向移植修補程式。必須重新啟動系統,此更新才會生效。

解決方案

更新受影響的 kernel 套件。

另請參閱

http://www.nessus.org/u?1a038323

Plugin 詳細資訊

嚴重性: Medium

ID: 65224

檔案名稱: centos_RHSA-2013-0621.nasl

版本: 1.9

類型: local

代理程式: unix

已發布: 2013/3/13

已更新: 2021/1/4

支持的傳感器: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure

風險資訊

VPR

風險因素: High

分數: 7.4

CVSS v2

風險因素: Medium

基本分數: 6.9

時間分數: 5.7

媒介: AV:L/AC:M/Au:N/C:C/I:C/A:C

時間媒介: E:F/RL:OF/RC:C

CVSS 評分資料來源: CVE-2013-0871

弱點資訊

CPE: p-cpe:/a:centos:centos:kernel, p-cpe:/a:centos:centos:kernel-PAE, p-cpe:/a:centos:centos:kernel-PAE-devel, p-cpe:/a:centos:centos:kernel-debug, p-cpe:/a:centos:centos:kernel-debug-devel, p-cpe:/a:centos:centos:kernel-devel, p-cpe:/a:centos:centos:kernel-doc, p-cpe:/a:centos:centos:kernel-headers, p-cpe:/a:centos:centos:kernel-xen, p-cpe:/a:centos:centos:kernel-xen-devel, cpe:/o:centos:centos:5

必要的 KB 項目: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2013/3/12

弱點發布日期: 2013/2/18

惡意利用途徑

CANVAS (CANVAS)

參考資訊

CVE: CVE-2013-0268, CVE-2013-0871

BID: 57838, 57986

RHSA: 2013:0621