Apache 2.2.x < 2.2.24 多個 XSS 弱點

medium Nessus Plugin ID 64912

Synopsis

遠端 Web 服務受到多個跨網站指令碼弱點影響。

描述

根據其標題,遠端主機上執行的 Apache 2.2.x 版本比 2.2.24 舊。因此可能受到以下跨網站指令碼弱點影響:

-存在與模組 mod_info、mod_status、 mod_imagemap、mod_ldap 和 mod_proxy_ftp,以及未逸出主機名稱與 URI 相關的錯誤,可導致跨網站指令碼攻擊。(CVE-2012-3499)

- 存在一個與 mod_proxy_balancer 模組的管理員介面相關的錯誤,可導致跨網站指令碼攻擊。(CVE-2012-4558)

請注意,Nessus 並未實際測試此問題,而是僅依據伺服器標題上的版本。

解決方案

升級至 Apache 2.2.24 或更新版本。此外,請確保受影響的模組目前未處於使用中。

另請參閱

https://archive.apache.org/dist/httpd/CHANGES_2.2.24

http://httpd.apache.org/security/vulnerabilities_22.html

Plugin 詳細資訊

嚴重性: Medium

ID: 64912

檔案名稱: apache_2_2_24.nasl

版本: 1.19

類型: remote

系列: Web Servers

已發布: 2013/2/27

已更新: 2018/6/29

風險資訊

VPR

風險因素: Low

分數: 3

CVSS v2

風險因素: Medium

基本分數: 4.3

時間分數: 3.2

媒介: AV:N/AC:M/Au:N/C:N/I:P/A:N

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: Medium

基本分數: 5.3

時間分數: 4.6

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:apache:http_server

必要的 KB 項目: installed_sw/Apache

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2013/2/26

弱點發布日期: 2013/2/18

參考資訊

CVE: CVE-2012-3499, CVE-2012-4558

BID: 58165

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990