Apache 2.4.x < 2.4.4 多個 XSS 弱點

medium Nessus Plugin ID 64893
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 web 伺服器可能受到多種跨網站指令碼處理弱點的影響。

描述

根據其標題,遠端主機上執行的 Apache 2.4.x 版本比 2.4.4 舊。因此受到以下跨網站指令碼弱點影響:

- 存在與模組 mod_info、mod_status、 mod_imagemap、mod_ldap 和 mod_proxy_ftp,以及未逸出主機名稱和 URI 相關的錯誤,可導致跨網站指令碼攻擊。(CVE-2012-3499)

- 存在與 mod_proxy_balancer 模組的管理員介面相關的錯誤,可導致跨網站指令碼攻擊。(CVE-2012-4558)

請注意,Nessus 並未實際測試此問題,而是僅依據伺服器標題上的版本。

解決方案

升級至 Apache 2.4.4 或更新版本。此外,請確保受影響的模組目前未處於使用中。

另請參閱

https://archive.apache.org/dist/httpd/CHANGES_2.4.4

http://httpd.apache.org/security/vulnerabilities_24.html

Plugin 詳細資訊

嚴重性: Medium

ID: 64893

檔案名稱: apache_2_4_4.nasl

版本: 1.19

類型: combined

代理程式: windows, macosx, unix

系列: Web Servers

已發布: 2013/2/26

已更新: 2021/1/28

相依性: apache_http_version.nasl, apache_http_server_nix_installed.nbin, apache_httpd_win_installed.nbin

風險資訊

CVSS 評分資料來源: CVE-2012-4558

VPR

風險因素: Low

分數: 3

CVSS v2

風險因素: Medium

基本分數: 4.3

時間分數: 3.2

媒介: AV:N/AC:M/Au:N/C:N/I:P/A:N

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: Medium

基本分數: 5.9

時間分數: 5.2

媒介: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:apache:http_server

必要的 KB 項目: installed_sw/Apache

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2013/2/25

弱點發布日期: 2013/2/18

參考資訊

CVE: CVE-2012-3499, CVE-2012-4558

BID: 58165

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990