Adobe AIR for Mac 3.x <= 3.5.0.600 多個弱點 (APSB12-27)

critical Nessus Plugin ID 63243

Synopsis

遠端 Mac OS X 主機包含一個受到多個弱點影響的 Adobe AIR 版本。

描述

根據其版本,遠端 Mac OS X 主機上之 Adobe AIR 3.x 的執行個體為 3.5.0.600 或更舊版本。因此,據報會受到多個弱點影響:

- 存在一個不明錯誤,可允許緩衝區溢位和任意程式碼執行。(CVE-2012-5676)

- 存在一個不明錯誤,可允許整數溢位和任意程式碼執行。(CVE-2012-5677)

- 存在一個不明錯誤,可能導致記憶體損毀和任意程式碼執行。(CVE-2012-5678)

解決方案

升級至 Adobe AIR 3.5.0.890 或更新版本。

另請參閱

http://www.zerodayinitiative.com/advisories/ZDI-13-021/

http://www.adobe.com/support/security/bulletins/apsb12-27.html

Plugin 詳細資訊

嚴重性: Critical

ID: 63243

檔案名稱: macosx_adobe_air_3_5_0_890.nasl

版本: 1.12

類型: local

代理程式: macosx

已發布: 2012/12/12

已更新: 2019/12/4

支持的傳感器: Nessus Agent

風險資訊

VPR

風險因素: High

分數: 8.9

CVSS v2

風險因素: Critical

基本分數: 10

時間分數: 8.7

媒介: AV:N/AC:L/Au:N/C:C/I:C/A:C

時間媒介: E:H/RL:OF/RC:C

CVSS 評分資料來源: CVE-2012-5678

弱點資訊

CPE: cpe:/a:adobe:air

必要的 KB 項目: MacOSX/Adobe_AIR/Version

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2012/12/11

弱點發布日期: 2012/12/11

參考資訊

CVE: CVE-2012-5676, CVE-2012-5677, CVE-2012-5678

BID: 56892, 56896, 56898