Adobe AIR for Mac 3.x <= 3.4.0.2710 多個弱點 (APSB12-24)

critical Nessus Plugin ID 62837

Synopsis

遠端 Mac OS X 主機包含一個受到多個弱點影響的 Adobe AIR 版本。

描述

根據其版本,遠端 Mac OS X 主機上之 Adobe AIR 的執行個體為 3.4.0.2710 或更舊版本。因此,據報會受到多個弱點影響:

- 存在數個不明問題,可能導致緩衝區溢位和任意程式碼執行。(CVE-2012-5274、CVE-2012-5275、CVE-2012-5276、CVE-2012-5277、CVE-2012-5280)

- 存在一個可導致任意程式碼執行的不明安全性繞過問題。(CVE-2012-5278)

- 存在一個可導致記憶體損毀和任意程式碼執行的不明問題。(CVE-2012-5279)

解決方案

升級至 Adobe AIR 3.5.0.600 或更新版本。

另請參閱

http://www.adobe.com/support/security/bulletins/apsb12-24.html

Plugin 詳細資訊

嚴重性: Critical

ID: 62837

檔案名稱: macosx_adobe_air_3_5_0_600.nasl

版本: 1.14

類型: local

代理程式: macosx

已發布: 2012/11/7

已更新: 2019/12/4

支持的傳感器: Nessus Agent

風險資訊

VPR

風險因素: High

分數: 8.9

CVSS v2

風險因素: Critical

基本分數: 10

時間分數: 8.7

媒介: AV:N/AC:L/Au:N/C:C/I:C/A:C

時間媒介: E:H/RL:OF/RC:C

CVSS 評分資料來源: CVE-2012-5280

弱點資訊

CPE: cpe:/a:adobe:air

必要的 KB 項目: MacOSX/Adobe_AIR/Version

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2012/11/6

弱點發布日期: 2012/11/6

參考資訊

CVE: CVE-2012-5274, CVE-2012-5275, CVE-2012-5276, CVE-2012-5277, CVE-2012-5278, CVE-2012-5279, CVE-2012-5280

BID: 56542, 56543, 56544, 56545, 56546, 56547, 56554