Apache 2.4.x < 2.4.3 多個弱點

medium Nessus Plugin ID 61644

Synopsis

遠端 Web 伺服器受到多個弱點影響。

描述

根據其標題,遠端主機上執行的 Apache 2.4.x 版本比 2.4.3 舊。因此,該應用程式受到以下弱點影響:

- 存在與「mod_negotiation」、「Multiviews」和不信任的上傳有關的輸入驗證錯誤,可能導致跨網站指令碼攻擊。
(CVE-2012-2687)

- 存在一個與 'mod_proxy_ajp' 和 'mod_proxy_http' 相關的錯誤,其可允許連線維持開啟狀態。此情形與特製的要求結合時可允許資訊洩漏。
(CVE-2012-3502)

請注意,Nessus 並未實際測試此問題,而是僅依據伺服器標題上的版本。

解決方案

升級至 Apache 2.4.3 或更新版本。

另請參閱

https://archive.apache.org/dist/httpd/CHANGES_2.4.3

http://httpd.apache.org/security/vulnerabilities_24.html

https://bz.apache.org/bugzilla/show_bug.cgi?id=53727

Plugin 詳細資訊

嚴重性: Medium

ID: 61644

檔案名稱: apache_2_4_3.nasl

版本: 1.21

類型: combined

代理程式: windows, macosx, unix

系列: Web Servers

已發布: 2012/8/23

已更新: 2022/4/11

組態: 啟用徹底檢查

支持的傳感器: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

風險資訊

VPR

風險因素: Low

分數: 3

CVSS v2

風險因素: Medium

基本分數: 4.3

時間分數: 3.2

媒介: AV:N/AC:M/Au:N/C:P/I:N/A:N

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2012-3502

CVSS v3

風險因素: Medium

基本分數: 5.3

時間分數: 4.6

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:apache:http_server

必要的 KB 項目: installed_sw/Apache

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2012/8/21

弱點發布日期: 2012/6/13

參考資訊

CVE: CVE-2012-2687, CVE-2012-3502

BID: 55131

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990