Scientific Linux 安全性更新:SL5.x i386/x86_64 上的核心

medium Nessus Plugin ID 61018

Synopsis

遠端 Scientific Linux 主機缺少一個或多個安全性更新。

描述

此更新可修正下列安全性問題:

- 在 Linux 核心的 av7110 模組的 dvb_ca_ioctl() 函式中發現一個遺失邊界檢查。如果系統使用需要 av7110 模組的舊版 DVB 卡,無權限的本機使用者可利用此瑕疵,導致拒絕服務或提升自己的權限。
(CVE-2011-0521,重要)

* 在 Linux 核心中,發現配置及釋放 NFSv4 (網路檔案系統版本 4) ACL 資料的方法互動中存有不一致情況。此不一致情況導致核心錯誤,這可由無權限的本機使用者,藉由 NFSv4 共用項目上屬於上述使用者所有的檔案加以觸發。
(CVE-2011-1090,中等)

- 在 Linux 核心網路實作的通用接收卸載 (GRO) 功能中發現一個 NULL 指標解除參照瑕疵。如果虛擬 LAN (VLAN) 的介面同時啟用了 GRO 和混雜模式,當該介面接收到格式錯誤的 VLAN 框架時,可造成拒絕服務。(CVE-2011-1478,中等)

- 在 Linux 核心的 install_special_mapping() 函式實作中,遺失安全性檢查可允許無權限的本機使用者繞過 mmap_min_addr 保護機制。(CVE-2010-4346,低)

- 在 Linux 核心的 task_show_regs() 實作中發現資訊洩漏。在 IBM S/390 系統上,無權限的本機使用者可利用此瑕疵讀取 /proc/[PID]/status 檔案,進而允許這些檔案探索處理程序的 CPU 暫存器值。(CVE-2011-0710,低)

- 在 Linux 核心的 mac_partition() 實作中發現一個遺失驗證檢查問題;該實作用於支援 Mac OS 作業系統上建立的檔案系統。本機攻擊者可利用此瑕疵,掛載含有特製磁碟分割的磁碟以造成拒絕服務。(CVE-2011-1010,低)

此更新還可修正數個錯誤。

必須重新啟動系統,此更新才會生效。

解決方案

更新受影響的套件。

另請參閱

http://www.nessus.org/u?810eeb6e

Plugin 詳細資訊

嚴重性: Medium

ID: 61018

檔案名稱: sl_20110412_kernel_on_SL5_x.nasl

版本: 1.6

類型: local

代理程式: unix

已發布: 2012/8/1

已更新: 2021/1/14

支持的傳感器: Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: Medium

基本分數: 6.9

媒介: AV:L/AC:M/Au:N/C:C/I:C/A:C

弱點資訊

CPE: x-cpe:/o:fermilab:scientific_linux

必要的 KB 項目: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

修補程式發佈日期: 2011/4/12

參考資訊

CVE: CVE-2010-4346, CVE-2011-0521, CVE-2011-0710, CVE-2011-1010, CVE-2011-1090, CVE-2011-1478