Scientific Linux 安全性更新:SL6.x i386/x86_64 上的核心

high Nessus Plugin ID 61012

Synopsis

遠端 Scientific Linux 主機缺少一個或多個安全性更新。

描述

此更新可修正下列安全性問題:

- 在 Linux 核心的資料流控制傳輸通訊協定 (SCTP) 實作中,發現 sctp_icmp_proto_unreachable() 函式有一個瑕疵。遠端攻擊者可利用此瑕疵造成拒絕服務。(CVE-2010-4526,重要)

- 在 Linux 核心的 av7110 模組的 dvb_ca_ioctl() 函式中發現一個遺失邊界檢查。如果系統使用需要 av7110 模組的舊版 DVB 卡,無權限的本機使用者可利用此瑕疵,導致拒絕服務或提升自己的權限。
(CVE-2011-0521,重要)

- 在 Linux 核心之 InfiniBand 實作設定新連線的方式中發現一個爭用情形。這可允許遠端使用者造成拒絕服務。
(CVE-2011-0695,重要)

- iowarrior_write() 函式中有一個堆積溢位瑕疵,可允許具有 IO-Warrior USB 裝置 (每報告支援 8 位元組以上) 存取權的使用者造成拒絕服務,或是提升其權限。
(CVE-2010-4656,中等)

* 在 Linux 乙太網路橋接器實作處理特定 IGMP (網際網路群組管理通訊協定) 封包的方式中發現一個瑕疵。在乙太網路橋接器中具有網路介面的系統上,無權限的本機使用者可利用此瑕疵造成系統當機 (CVE-2011-0716,中等)

- 在 Linux 核心網路實作的通用接收卸載 (GRO) 功能中發現一個 NULL 指標解除參照瑕疵。如果虛擬 LAN (VLAN) 的介面同時啟用了 GRO 和混雜模式,當該介面接收到格式錯誤的 VLAN 框架時,可造成拒絕服務。(CVE-2011-1478,中等)

- Linux 核心中的缺少初始化瑕疵可造成資訊洩漏。(CVE-2010-3296,低)

- 在 Linux 核心的 install_special_mapping() 函式實作中,遺失安全性檢查可允許無權限的本機使用者繞過 mmap_min_addr 保護機制。(CVE-2010-4346,低)

- 當 TKIP 對策啟用時,在 Linux 核心的 ORiNOCO 無線延伸模組支援實作中,orinoco_ioctl_set_auth() 函式的邏輯錯誤可使 TKIP 對策無效,因為該對策會啟用卡片而非將其關閉。(CVE-2010-4648,低)

- 在 Linux 核心的 ethtool IOCTL 處置程式中,發現 ethtool_get_regs() 函式有一個遺失初始化瑕疵。具有 CAP_NET_ADMIN 功能的本機使用者可利用此瑕疵導致資訊洩漏。(CVE-2010-4655,低)

- 在 Linux 核心的 task_show_regs() 實作中發現資訊洩漏。在 IBM S/390 系統上,無權限的本機使用者可利用此瑕疵讀取 /proc/[PID]/status 檔案,進而允許這些檔案探索處理程序的 CPU 暫存器值。(CVE-2011-0710,低)

此更新還可修正數個錯誤。

必須重新啟動系統,此更新才會生效。

解決方案

更新受影響的套件。

另請參閱

http://www.nessus.org/u?d1fa786b

Plugin 詳細資訊

嚴重性: High

ID: 61012

檔案名稱: sl_20110407_kernel_on_SL6_x.nasl

版本: 1.6

類型: local

代理程式: unix

已發布: 2012/8/1

已更新: 2021/1/14

支持的傳感器: Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: High

基本分數: 7.1

媒介: AV:N/AC:M/Au:N/C:N/I:N/A:C

弱點資訊

CPE: x-cpe:/o:fermilab:scientific_linux

必要的 KB 項目: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

修補程式發佈日期: 2011/4/7

弱點發布日期: 2010/9/30

參考資訊

CVE: CVE-2010-3296, CVE-2010-4346, CVE-2010-4526, CVE-2010-4648, CVE-2010-4655, CVE-2010-4656, CVE-2011-0521, CVE-2011-0695, CVE-2011-0710, CVE-2011-0716, CVE-2011-1478