Scientific Linux 安全性更新:SL4.x、SL5.x i386/x86_64 上的 firefox

high Nessus Plugin ID 60818

Synopsis

遠端 Scientific Linux 主機缺少一個或多個安全性更新。

描述

處理格式有誤之網頁內容時發現多個瑕疵。包含惡意內容的網頁可造成 Firefox 損毀,或可能利用執行 Firefox 之使用者的權限來執行任意程式碼。(CVE-2010-1208、CVE-2010-1209、CVE-2010-1211、CVE-2010-1212、CVE-2010-1214、CVE-2010-1215、CVE-2010-2752、CVE-2010-2753)

在 Firefox 為某些 PNG 影像解碼的方式中發現一個記憶體損毀瑕疵。攻擊者可建立一個特製的 PNG 影像,當開啟該檔案時,可導致 Firefox 當機,亦可能會以執行 Firefox 的使用者權限來執行任意程式碼。(CVE-2010-1205)

在 Firefox 中發現數個同源原則繞過瑕疵。攻擊者可建立一個惡意網頁,一旦受害者進入瀏覽,其使用 Firefox 載入之其他網站上的私人資料就會遭到竊取。(CVE-2010-0654、CVE-2010-1207、CVE-2010-1213、CVE-2010-2754)

在 Firefox 用於向使用者呈現位置列的方式中發現一個瑕疵。惡意網站可誘騙使用者以為自己正在造訪位置列所報告的網站,但其實他們瀏覽的是攻擊者控制內容的頁面。(CVE-2010-1206)

當造訪安全網頁時,在 Firefox 顯示位置列的方式中發現一個瑕疵。惡意伺服器可使用此瑕疵來顯示看似源自安全伺服器的資料,即使其實不是。(CVE-2010-2751)

在 Firefox 顯示某些格式錯誤之字元的方式中發現一個瑕疵。惡意網頁可使用此瑕疵來繞過某些字串清理方法,進而顯示惡意資訊給使用者。(CVE-2010-1210)

如需這些瑕疵的詳細技術資訊,請參閱 Firefox 3.6.7 的 Mozilla 安全性公告。

安裝更新之後,Firefox 必須重新啟動,變更才會生效。

解決方案

更新受影響的 firefox、xulrunner 和/或 xulrunner-devel 套件。

另請參閱

http://www.nessus.org/u?9501aee4

Plugin 詳細資訊

嚴重性: High

ID: 60818

檔案名稱: sl_20100720_firefox_on_SL4_x.nasl

版本: 1.8

類型: local

代理程式: unix

已發布: 2012/8/1

已更新: 2021/1/14

支持的傳感器: Nessus Agent

風險資訊

VPR

風險因素: High

分數: 7.4

CVSS v2

風險因素: High

基本分數: 9.3

媒介: AV:N/AC:M/Au:N/C:C/I:C/A:C

弱點資訊

CPE: x-cpe:/o:fermilab:scientific_linux

必要的 KB 項目: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

修補程式發佈日期: 2010/7/20

弱點發布日期: 2010/2/18

參考資訊

CVE: CVE-2010-0654, CVE-2010-1205, CVE-2010-1206, CVE-2010-1207, CVE-2010-1208, CVE-2010-1209, CVE-2010-1210, CVE-2010-1211, CVE-2010-1212, CVE-2010-1213, CVE-2010-1214, CVE-2010-1215, CVE-2010-2751, CVE-2010-2752, CVE-2010-2753, CVE-2010-2754

CWE: 94