Scientific Linux 安全性更新:SL4.x、SL5.x i386/x86_64 上的 thunderbird

critical Nessus Plugin ID 60750
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Scientific Linux 主機缺少一個安全性更新。

描述

處理格式有誤之 HTML 郵件內容時發現多個瑕疵。包含惡意內容的 HTML 郵件訊息可導致 Thunderbird 當機,亦可能會利用執行 Thunderbird 之使用者的權限來執行任意程式碼。(CVE-2009-2462、CVE-2009-2463、CVE-2009-2466、CVE-2009-3072、CVE-2009-3075、CVE-2009-3380、CVE-2009-3979、CVE-2010-0159)

在 Thunderbird 中發現釋放後使用瑕疵。攻擊者可利用此瑕疵造成 Thunderbird 當機,或可能以執行 Thunderbird 的使用者權限執行任意程式碼。(CVE-2009-3077)

在 Thunderbird 套用至浮點轉換常式的字串中,發現堆積型緩衝區溢位瑕疵。包含惡意 JavaScript 的 HTML 郵件訊息可導致 Thunderbird 當機,或可能利用 Thunderbird 使用者的權限執行任意程式碼。
(CVE-2009-0689)

在 Thunderbird 中發現釋放後使用瑕疵。在記憶體不足的情況下,檢視包含惡意內容的 HTML 郵件訊息,可導致 Thunderbird 利用 Thunderbird 的使用者權限執行任意程式碼。(CVE-2009-1571)

在 Thunderbird 為已下載檔案建立暫存檔名稱的方式中發現瑕疵。如果本機攻擊者知道 Thunderbird 即將下載的檔案名稱,便可利用任意內容來取代該檔案的內容。(CVE-2009-3274)

下載檔案時,在 Thunderbird 顯示由右至左覆寫字元的方式中發現瑕疵。在這些情況下,標題列中顯示的名稱與對話方塊內文中顯示的名稱不同。攻擊者可利用此瑕疵誘騙使用者下載檔案名或副檔名不同於使用者預期的檔案。(CVE-2009-3376)

在 Thunderbird 處理 SOCKS5 Proxy 回覆的方式中發現瑕疵。惡意 SOCKS5 伺服器可傳送特製的回覆,進而導致 Thunderbird 當機。(CVE-2009-2470)

新增及移除 PKCS #11 模組時,對話方塊中的說明資訊不足。能誘騙使用者安裝惡意 PKCS #11 模組的攻擊者,可利用此瑕疵於使用者電腦上安裝其自身的憑證授權單位 (Certificate Authority) 憑證,進而誘騙使用者認為自己正在檢視受信任的內容,或利用 Thunderbird 使用者的權限執行任意程式碼。(CVE-2009-3076)

Thunderbird 的所有執行中執行個體都必須重新啟動,更新才能生效。

解決方案

更新受影響的 thunderbird 套件。

另請參閱

http://www.nessus.org/u?f3671dbd

Plugin 詳細資訊

嚴重性: Critical

ID: 60750

檔案名稱: sl_20100317_thunderbird_on_SL4_x.nasl

版本: 1.8

類型: local

代理程式: unix

已發布: 2012/8/1

已更新: 2021/1/14

相依性: ssh_get_info.nasl

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: Critical

基本分數: 10

媒介: AV:N/AC:L/Au:N/C:C/I:C/A:C

弱點資訊

CPE: x-cpe:/o:fermilab:scientific_linux

必要的 KB 項目: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

修補程式發佈日期: 2010/3/17

弱點發布日期: 2009/7/1

參考資訊

CVE: CVE-2009-0689, CVE-2009-1571, CVE-2009-2462, CVE-2009-2463, CVE-2009-2466, CVE-2009-2470, CVE-2009-3072, CVE-2009-3075, CVE-2009-3076, CVE-2009-3077, CVE-2009-3274, CVE-2009-3376, CVE-2009-3380, CVE-2009-3979, CVE-2010-0159

CWE: 16, 20, 94, 119, 189, 399