PHP 5.3.x < 5.3.15 多個弱點

critical Nessus Plugin ID 60085
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Web 伺服器使用受到多個弱點影響的 PHP 版本。

描述

根據其標題,遠端主機上安裝的 PHP 版本是比 5.3.15 舊的 5.3.x,因此可能受到以下弱點影響:

- 檔案「main/streams/streams.c」的函式「_php_stream_scandir」中存在不明溢位弱點。(CVE-2012-2688)

- 存在一個不明錯誤,可允許繞過「open_basedir」限制。
(CVE-2012-3365)

解決方案

升級至 PHP 5.3.15 版或更新版本。

另請參閱

http://www.php.net/ChangeLog-5.php#5.3.15

Plugin 詳細資訊

嚴重性: Critical

ID: 60085

檔案名稱: php_5_3_15.nasl

版本: 1.10

類型: remote

系列: CGI abuses

已發布: 2012/7/20

已更新: 2021/1/19

相依性: php_version.nasl

風險資訊

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: Critical

基本分數: 10

時間分數: 7.4

媒介: AV:N/AC:L/Au:N/C:C/I:C/A:C

時間媒介: E:U/RL:OF/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可輕鬆利用: No exploit is required

修補程式發佈日期: 2012/7/19

弱點發布日期: 2012/7/19

參考資訊

CVE: CVE-2012-2688, CVE-2012-3365

BID: 54612, 54638