FreeBSD : FreeBSD -- OpenSSL 多個弱點 (2ae114de-c064-11e1-b5e0-000c299b62e1)

high Nessus Plugin ID 59747
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 FreeBSD 主機缺少一個或多個安全性相關更新。

描述

問題描述:

當做接受 SSL 3.0 交握的用戶端或伺服器運作時,OpenSSL 無法清除 SSL 3.0 記錄中,當做區塊加密填補使用的位元組。因此,每次記錄可能會將最多 15 位元組的未初始化記憶體加密並傳送至 SSL 對等節點。其中可能會含有先前所釋放記憶體中的敏感內容。
[CVE-2011-4576]

重新啟動交握的 OpenSSL 支援,才能在拒絕服務攻擊中使用 Server Gated Cryptography (SGC)。[CVE-2011-4619]

如果在透過啟用 X509_V_FLAG_POLICY_CHECK 旗標驗證 X509 憑證時,應用程式使用 OpenSSL 的憑證原則檢查,則原則檢查失敗可能會導致重複釋放。
[CVE-2011-4109]

OpenSSL PKCS #7 程式碼中有一個弱點,可在 Bleichenbacher 對 PKCS #1 v1.5 RSA 填補的攻擊 (亦稱為 Million Message Attack (MMA)) 中遭惡意利用。[CVE-2012-0884]

在 OpenSSL 中,d2i_*_bio 和 d2i_*_fp 函式所使用的 asn1_d2i_read_bio() 函式含有多個整數錯誤,剖析編碼的 ASN.1 資料時,這些錯誤可能會造成記憶體損毀。此錯誤可能會在剖析未受信任之 ASN.1 資料的系統上發生,例如 X.509 憑證或 RSA 公開金鑰。[CVE-2012-2110]

解決方案

更新受影響的套件。

另請參閱

http://www.nessus.org/u?32392d4e

Plugin 詳細資訊

嚴重性: High

ID: 59747

檔案名稱: freebsd_pkg_2ae114dec06411e1b5e0000c299b62e1.nasl

版本: 1.16

類型: local

已發布: 2012/6/28

已更新: 2021/1/6

相依性: ssh_get_info.nasl

組態: 啟用 Paranoid 模式

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: High

基本分數: 9.3

時間分數: 7.3

媒介: AV:N/AC:M/Au:N/C:C/I:C/A:C

時間媒介: E:POC/RL:OF/RC:C

弱點資訊

CPE: p-cpe:/a:freebsd:freebsd:FreeBSD, cpe:/o:freebsd:freebsd

必要的 KB 項目: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info, Settings/ParanoidReport

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2012/6/27

弱點發布日期: 2012/5/3

參考資訊

CVE: CVE-2011-4109, CVE-2011-4576, CVE-2011-4619, CVE-2012-0884, CVE-2012-2110

BID: 51281, 52428, 53158

FreeBSD: SA-12:01.openssl