CentOS 6 : 核心 (CESA-2012:0350)

high Nessus Plugin ID 58275
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 CentOS 主機缺少一個或多個安全性更新。

描述

現已提供適用於 Red Hat Enterprise Linux 6 的更新版核心套件,可修正各種安全性問題與一些錯誤。

Red Hat 安全性回應團隊已將此更新評等為具有中等安全性影響。可針對每個弱點從〈參照〉一節的 CVE 連結中取得常見弱點評分系統 (CVSS) 的基本分數,其中包含有關嚴重性評等的詳細資訊。

kernel 套件中包含 Linux 核心,這是任何 Linux 作業系統的核心。

此更新可修正下列安全性問題:

* Linux 核心的 XFS 檔案系統實作處理具有過長路徑名稱的連結時,發現了緩衝區溢位瑕疵。
無權限的本機使用者可利用此瑕疵引發拒絕服務,或透過掛載特製的磁碟提升其權限。(CVE-2011-4077,中等)

* ghash_update() 及 ghash_final() 中的瑕疵可讓無權限的本機使用者造成拒絕服務。(CVE-2011-4081,中等)

* 在 Linux 核心的日誌記錄區塊裝置 (JBD) 中發現一個瑕疵。無權限的本機使用者可利用此瑕疵,透過掛載特製的 ext3 或 ext4 磁碟來使系統當機。
(CVE-2011-4132,中等)

* 據發現,在 Linux 核心的 KVM (核心型虛擬機器) 子系統中,kvm_vm_ioctl_assign_device() 函式並未檢查要求裝置指派的使用者是否具有權限。
主機上的無權限本機使用者可指派未使用的 PCI 裝置,甚或是正在使用且個別驅動程式未正確宣告資源的裝置,這可導致主機當機。(CVE-2011-4347,中等)

* 透過 sendmmsg() 系統呼叫來叫用 Linux 核心的 __sys_sendmsg() 函式時,在該函式存取使用者空間記憶體的方法中發現兩個瑕疵。無權限的本機使用者可利用這些瑕疵而導致拒絕服務。(CVE-2011-4594,中等)

* RHSA-2011:1530 核心更新將整數溢位瑕疵引入 Linux 核心。在 PowerPC 系統上,無權限的本機使用者可利用此瑕疵來引發拒絕服務。(CVE-2011-4611,中等)

* 未設定虛擬中斷控制器時,在 Linux 核心的 KVM 子系統處理 PIT (可程式化間隔計時器) IRQs (中斷要求) 的方式中發現一個瑕疵。主機上的無權限本機使用者可迫使此情況發生,進而導致主機當機。(CVE-2011-4622,中等)

* 在 Linux 核心之 XFS 檔案系統實作處理磁碟上存取控制清單 (ACL) 的方法中發現一個瑕疵。無權限的本機使用者可利用此瑕疵引發拒絕服務,或透過掛載特製的磁碟提升其權限。
(CVE-2012-0038,中等)

* 在 Linux 核心之 KVM Hypervisor 實作模擬 32 位元來賓系統呼叫指令的方法中發現一個瑕疵。無權限的來賓使用者可觸發此瑕疵而讓來賓當機。
(CVE-2012-0045,中等)

* 在 Linux 核心的 igmp_heard_query() 函式中,發現一個除以零瑕疵。能夠傳送特定 IGMP (網際網路群組管理通訊協定) 封包至目標系統的攻擊者可利用此瑕疵引發拒絕服務。(CVE-2012-0207,中等)

Red Hat 要感謝 Nick Bowler 報告 CVE-2011-4081;
Sasha Levin 報告 CVE-2011-4347;Tetsuo Handa 報告 CVE-2011-4594;Maynard Johnson 報告 CVE-2011-4611;Wang Xi 報告 CVE-2012-0038;Stephan Bärwolf 報告 CVE-2012-0045;以及 Simon McVittie 報告 CVE-2012-0207。
上游確認 Mathieu Desnoyers 是 CVE-2011-4594 的原始報告者。

此更新還可修正數個錯誤。這些變更的相關文件近期將可從<參照>一節中的「技術提示」文件連結中取得。

使用者應升級至這些更新版套件,其中包含反向移植修補程式,可更正這些問題並修正錯誤,如「技術提示」文件中所述。必須重新啟動系統,此更新才會生效。

解決方案

更新受影響的 kernel 套件。

另請參閱

http://www.nessus.org/u?ec4c33b1

Plugin 詳細資訊

嚴重性: High

ID: 58275

檔案名稱: centos_RHSA-2012-0350.nasl

版本: 1.18

類型: local

代理程式: unix

已發布: 2012/3/8

已更新: 2021/1/4

相依性: ssh_get_info.nasl

風險資訊

CVSS 評分資料來源: CVE-2012-0207

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: High

基本分數: 7.8

時間分數: 6.4

媒介: AV:N/AC:L/Au:N/C:N/I:N/A:C

時間媒介: E:F/RL:OF/RC:C

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 7

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

時間媒介: E:F/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:centos:centos:kernel, p-cpe:/a:centos:centos:kernel-debug, p-cpe:/a:centos:centos:kernel-debug-devel, p-cpe:/a:centos:centos:kernel-devel, p-cpe:/a:centos:centos:kernel-doc, p-cpe:/a:centos:centos:kernel-firmware, p-cpe:/a:centos:centos:kernel-headers, p-cpe:/a:centos:centos:perf, p-cpe:/a:centos:centos:python-perf, cpe:/o:centos:centos:6

必要的 KB 項目: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2012/3/7

弱點發布日期: 2012/1/27

惡意利用途徑

Core Impact

參考資訊

CVE: CVE-2011-4077, CVE-2011-4081, CVE-2011-4132, CVE-2011-4347, CVE-2011-4594, CVE-2011-4611, CVE-2011-4622, CVE-2012-0038, CVE-2012-0045, CVE-2012-0207

BID: 50366, 50370, 50663, 50811, 50984, 51081, 51172, 51343, 51380, 51389

RHSA: 2012:0350