CentOS 4 / 5 / 6:libpng / libpng10 (CESA-2012: 0317)

medium Nessus Plugin ID 58042
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 CentOS 主機缺少一個或多個安全性更新。

描述

現已提供適用於 Red Hat Enterprise Linux 4、5 和 6 的更新版 libpng 和 libpng10 套件,可修正一個安全性問題。

Red Hat 安全性回應團隊已將此更新評等為具有重要安全性影響。可從〈參照〉一節的 CVE 連結中取得常見弱點評分系統 (CVSS) 的基本分數,其中包含有關嚴重性評等的詳細資訊。

libpng 套件含有用於建立和操控 PNG (可攜式網路圖形) 影像格式檔案的函式程式庫。

在 libpng 中發現一個堆積型緩衝區溢位瑕疵。攻擊者可建立特別構建的 PNG 影像,此影像在開啟時可導致使用 libpng 的應用程式損毀,或可能以執行此應用程式的使用者權限來執行任意程式碼。(CVE-2011-3026)

libpng 與 libpng10 的使用者應升級至這些更新版套件,其中包含可更正此問題的反向移植修補程式。使用 libpng 或 libpng10 的所有執行中應用程式都必須重新啟動,更新才能生效。

解決方案

更新受影響的 libpng 和/或 libpng10 套件。

另請參閱

http://www.nessus.org/u?36932609

http://www.nessus.org/u?b6dc1551

http://www.nessus.org/u?54a74547

http://www.nessus.org/u?bab4d037

Plugin 詳細資訊

嚴重性: Medium

ID: 58042

檔案名稱: centos_RHSA-2012-0317.nasl

版本: 1.15

類型: local

代理程式: unix

已發布: 2012/2/21

已更新: 2021/1/4

相依性: ssh_get_info.nasl

風險資訊

CVSS 評分資料來源: CVE-2011-3026

VPR

風險因素: Medium

分數: 5.8

CVSS v2

風險因素: Medium

基本分數: 6.8

媒介: AV:N/AC:M/Au:N/C:P/I:P/A:P

弱點資訊

CPE: p-cpe:/a:centos:centos:libpng, p-cpe:/a:centos:centos:libpng-devel, p-cpe:/a:centos:centos:libpng-static, p-cpe:/a:centos:centos:libpng10, p-cpe:/a:centos:centos:libpng10-devel, cpe:/o:centos:centos:4, cpe:/o:centos:centos:5, cpe:/o:centos:centos:6

必要的 KB 項目: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

修補程式發佈日期: 2012/2/20

弱點發布日期: 2012/2/16

參考資訊

CVE: CVE-2011-3026

RHSA: 2012:0317