PHP < 5.3.9 多種弱點

high Nessus Plugin ID 57537
新推出!弱點優先順序評分 (VPR)

Tenable 會為每個弱點計算動態 VPR。VPR 將弱點資訊與威脅情報和機器學習演算法加以結合,藉此預測攻擊者最有可能利用哪些弱點發動攻擊。查看詳細資訊: VPR 是什麼?它跟 CVSS 有何不同?

VPR 評分: 5.7

Synopsis

遠端 Web 伺服器使用受到多個瑕疵影響的 PHP 版本。

描述

根據其標題,遠端主機上安裝的 PHP 版本舊於 5.3.9。因此,據稱其可能受到以下安全性問題影響:

- PHP 5.3.7 和 5.3.8 的「is_a()」函式觸發對「__autoload()」的呼叫。(CVE-2011-3379)

- 可以傳送多個特製的要求,其中包含的參數值會在對雜湊表中的儲存運算雜湊值時造成雜湊衝突,從而導致拒絕服務狀況。(CVE-2011-4885)
- exif.c 的 exif_process_IFD_TAG 函式中存在整數溢位,可能允許遠端攻擊者讀取任意記憶體位置或造成拒絕服務狀況。此弱點僅影響 32 位元平台上的 PHP 5.4.0 beta2。(CVE-2011-4566)

- 對於 libxslt 的呼叫不限於透過 xsltSetSecurityPrefs(),可允許攻擊者建立或覆寫檔案,導致任意程式碼執行。(CVE-2012-0057)

- 函式「tidy_diagnose」中存在錯誤,可能導致攻擊者造成應用程式將 NULL 指標解除參照。這會導致應用程式癱瘓。(CVE-2012-0781)

-「PDORow」實作包含錯誤,可能導致應用程式在對於工作階段功能進行互動處理時癱瘓。(CVE-2012-0788)

- 時區處理(例如重複呼叫函式「strtotime」)中存在錯誤,可能允許透過記憶體消耗造成拒絕服務攻擊。
(CVE-2012-0789)

解決方案

升級為 PHP 5.3.9 或更新版本。

另請參閱

https://www.tenable.com/security/research/tra-2012-01

http://xhe.myxwiki.org/xwiki/bin/view/XSLT/Application_PHP5

http://www.php.net/archive/2012.php#id2012-01-11-1

https://seclists.org/bugtraq/2012/Jan/91

https://bugs.php.net/bug.php?id=55475

https://bugs.php.net/bug.php?id=55776

https://bugs.php.net/bug.php?id=53502

http://www.php.net/ChangeLog-5.php#5.3.9

Plugin 詳細資訊

嚴重性: High

ID: 57537

檔案名稱: php_5_3_9.nasl

版本: 1.24

類型: remote

系列: CGI abuses

已發布: 2012/1/13

已更新: 2021/1/19

相依性: php_version.nasl

風險資訊

風險因素: High

VPR 評分: 5.7

CVSS v2.0

基本分數: 7.5

時間分數: 6.5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:H/RL:OF/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可輕鬆利用: No exploit is required

修補程式發佈日期: 2012/1/11

弱點發布日期: 2011/9/23

惡意利用途徑

Core Impact

參考資訊

CVE: CVE-2011-3379, CVE-2011-4566, CVE-2011-4885, CVE-2012-0057, CVE-2012-0781, CVE-2012-0788, CVE-2012-0789

BID: 49754, 50907, 51193, 51806, 51952, 51992, 52043