Debian DSA-2368-1:lighttpd - 多個弱點 (BEAST)

medium Nessus Plugin ID 57508
新推出!弱點優先順序評分 (VPR)

Tenable 會為每個弱點計算動態 VPR。VPR 將弱點資訊與威脅情報和機器學習演算法加以結合,藉此預測攻擊者最有可能利用哪些弱點發動攻擊。查看詳細資訊: VPR 是什麼?它跟 CVSS 有何不同?

VPR 評分: 2.9

Synopsis

遠端 Debian 主機缺少安全性更新。

描述

在 lighttpd (需要最低記憶體使用量、小型且快速的 webserver) 中發現數個弱點。

- CVE-2011-4362 Xi Wang 發現,用於在 HTTP 驗證期間解碼使用者輸入的 base64 解碼常式,在處理使用者輸入時受到一個正負號問題影響。因此有可能強制 lighttpd 執行超出邊界讀取,進而導致拒絕服務情形。

- CVE-2011-3389 在啟用了 SSL 的虛擬主機上使用 CBC 密碼來與特定用戶端通訊時,所謂的 'BEAST' 攻擊會允許攔截式攻擊者透過 HTTPS 工作階段上的列塊選擇邊界攻擊 (BCBA),取得純文字 HTTP 流量。從技術上來說,這並不是 lighttpd 弱點。但是 lighttpd 提供了停用 CBC 密碼的可能性,可做為減輕此問題的因應措施。

此更新預設為包含本選項。建議系統管理員讀取此更新的 NEWS 檔案 (因為此更新可能會中斷舊的用戶端)。

解決方案

升級 lighttpd 套件。

針對舊的穩定發行版本 (lenny),此問題已在 1.4.19-5+lenny3 版中修正。

針對穩定的發行版本 (squeeze),此問題已在 1.4.28-2+squeeze1 版中修正。

另請參閱

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=652726

https://security-tracker.debian.org/tracker/CVE-2011-4362

https://security-tracker.debian.org/tracker/CVE-2011-3389

https://packages.debian.org/source/squeeze/lighttpd

https://www.debian.org/security/2011/dsa-2368

Plugin 詳細資訊

嚴重性: Medium

ID: 57508

檔案名稱: debian_DSA-2368.nasl

版本: 1.13

類型: local

代理程式: unix

已發布: 2012/1/12

已更新: 2021/1/11

相依性: ssh_get_info.nasl

風險資訊

風險因素: Medium

VPR 評分: 2.9

CVSS v2.0

基本分數: 5

時間分數: 3.9

媒介: AV:N/AC:L/Au:N/C:N/I:N/A:P

時間媒介: E:POC/RL:OF/RC:C

弱點資訊

CPE: p-cpe:/a:debian:debian_linux:lighttpd, cpe:/o:debian:debian_linux:5.0, cpe:/o:debian:debian_linux:6.0

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2011/12/20

參考資訊

CVE: CVE-2011-3389, CVE-2011-4362

BID: 49778, 50851

DSA: 2368