Apache HTTP Server mod_proxy 反向代理伺服器資訊洩漏

medium Nessus Plugin ID 56972
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

在遠端主機上執行的 Web 伺服器具有一個資訊洩漏弱點。

描述

執行於遠端主機上的 Apache HTTP Server 版本受到資訊洩漏弱點的影響。設定為反向代理伺服器時,不當使用 RewriteRule 和 ProxyPassMatch 指示詞可造成 web 伺服器代理任意主機的要求。這允許遠端攻擊者間接將要求傳送到內部網路伺服器。

解決方案

升級至 Apache httpd 2.2.22 或更新版本。

另請參閱

http://httpd.apache.org/security/vulnerabilities_22.html

http://www.nessus.org/u?7fedbcf7

https://community.qualys.com/blogs/securitylabs/tags/cve-2011-4317

http://thread.gmane.org/gmane.comp.apache.devel/46440

Plugin 詳細資訊

嚴重性: Medium

ID: 56972

檔案名稱: apache_mod_proxy_info_leak.nasl

版本: 1.17

類型: remote

系列: Web Servers

已發布: 2011/11/29

已更新: 2018/6/27

相依性: http_version.nasl

風險資訊

VPR

風險因素: Medium

分數: 4.2

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.9

媒介: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

時間媒介: CVSS2#E:POC/RL:OF/RC:C

弱點資訊

CPE: cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2012/1/31

弱點發布日期: 2011/10/5

參考資訊

CVE: CVE-2011-3368, CVE-2011-4317

BID: 49957, 50802

EDB-ID: 17969