Ubuntu 8.04 LTS / 10.04 LTS / 10.10 / 11.04 / 11.10:apache2、apache2-mpm-itk 弱點 (USN-1259-1)

medium Nessus Plugin ID 56778
新推出!弱點優先順序評分 (VPR)

Tenable 會為每個弱點計算動態 VPR。VPR 將弱點資訊與威脅情報和機器學習演算法加以結合,藉此預測攻擊者最有可能利用哪些弱點發動攻擊。查看詳細資訊: VPR 是什麼?它跟 CVSS 有何不同?

VPR 評分: 4.2

Synopsis

遠端 Ubuntu 主機缺少一個或多個安全性相關修補程式。

描述

據發現,Apache 中的 mod_proxy 模組未與反向代理伺服器組態中的 RewriteRule 和 ProxyPassMatch 模式比對正確互動。這可讓遠端攻擊者聯絡 Proxy 背後,非預定用於外部洩漏的內部 Webserver。(CVE-2011-3368)

Stefano Nichele 發現,Apache 中的 mod_proxy_ajp 模組與特定組態的 mod_proxy_balancer 搭配使用時,可允許遠端攻擊者透過格式錯誤的 HTTP 要求,造成拒絕服務。(CVE-2011-3348)

Samuel Montosa 發現,Apache 的 ITK 多處理模組未正確處理用於指定 NiceValue 而非 AssignUserID 的特定組態區段,其使 Apache 無法正確放置權限。受此問題影響的只有 Ubuntu 10.04 LTS、 Ubuntu 10.10 和 Ubuntu 11.04。(CVE-2011-1176)

USN 1199-1 修正了 Apache 中 byterange 篩選器的弱點。
上游修補程式處理特定位元組範圍要求時,在 Apache 中引入了一個迴歸。此更新會修正這個問題。

在 Apache 的位元組範圍篩選中發現一個瑕疵。遠端攻擊者可惡意利用該瑕疵,透過資源耗盡而引發拒絕服務。

解決方案

更新受影響的 apache2-mpm-itk、apache2.2-bin 和/或 apache2.2-common 套件。

另請參閱

https://usn.ubuntu.com/1259-1/

Plugin 詳細資訊

嚴重性: Medium

ID: 56778

檔案名稱: ubuntu_USN-1259-1.nasl

版本: 1.15

類型: local

代理程式: unix

已發布: 2011/11/11

已更新: 2019/9/19

相依性: ssh_get_info.nasl

風險資訊

風險因素: Medium

VPR 評分: 4.2

CVSS v2.0

基本分數: 5

時間分數: 3.9

媒介: AV:N/AC:L/Au:N/C:P/I:N/A:N

時間媒介: E:POC/RL:OF/RC:C

弱點資訊

CPE: p-cpe:/a:canonical:ubuntu_linux:apache2-mpm-itk, p-cpe:/a:canonical:ubuntu_linux:apache2.2-bin, p-cpe:/a:canonical:ubuntu_linux:apache2.2-common, cpe:/o:canonical:ubuntu_linux:10.04:-:lts, cpe:/o:canonical:ubuntu_linux:10.10, cpe:/o:canonical:ubuntu_linux:11.04, cpe:/o:canonical:ubuntu_linux:11.10, cpe:/o:canonical:ubuntu_linux:8.04:-:lts

必要的 KB 項目: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2011/11/10

弱點發布日期: 2011/3/29

參考資訊

CVE: CVE-2011-1176, CVE-2011-3348, CVE-2011-3368

BID: 46953, 49616, 49957

USN: 1259-1