Ubuntu 10.04 LTS / 10.10 / 11.04 : kde4libs 弱點 (USN-1248-1)

medium Nessus Plugin ID 56647
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Ubuntu 主機缺少一個或多個安全性相關修補程式。

描述

Tim Brown 發現,當顯示 SSL 憑證的共用名稱 (CN) 時,KDE-Libs 中的 KSSL 並未正確執行輸入驗證。攻擊者可惡意利用此問題來偽造共用名稱,其可用來發動誘騙使用者接受偽造憑證的攻擊。此問題僅影響 Ubuntu 10.04 LTS 和 Ubuntu 10.10。(CVE-2011-3365)

據發現,KDE-Libs 中的 KIO 在代理伺服器驗證期間並未正確執行輸入驗證。攻擊者可惡意利用此問題來修改領域與代理伺服器 URL 的顯示。

解決方案

更新受影響的 kdelibs5 及/或 libkio5 套件。

另請參閱

https://usn.ubuntu.com/1248-1/

Plugin 詳細資訊

嚴重性: Medium

ID: 56647

檔案名稱: ubuntu_USN-1248-1.nasl

版本: 1.10

類型: local

代理程式: unix

已發布: 2011/10/26

已更新: 2019/9/19

相依性: ssh_get_info.nasl

風險資訊

VPR

風險因素: Low

分數: 3.4

CVSS v2

風險因素: Medium

基本分數: 4.3

時間分數: 3.2

媒介: AV:N/AC:M/Au:N/C:N/I:P/A:N

時間媒介: E:U/RL:OF/RC:C

弱點資訊

CPE: p-cpe:/a:canonical:ubuntu_linux:kdelibs5, p-cpe:/a:canonical:ubuntu_linux:libkio5, cpe:/o:canonical:ubuntu_linux:10.04:-:lts, cpe:/o:canonical:ubuntu_linux:10.10, cpe:/o:canonical:ubuntu_linux:11.04

必要的 KB 項目: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2011/10/25

弱點發布日期: 2011/11/29

參考資訊

CVE: CVE-2011-3365

BID: 49925

USN: 1248-1