FreeBSD:OpenSSL -- 多個弱點 (2ecb7b20-d97e-11e0-b2e2-00215c6a37bb)

medium Nessus Plugin ID 56117
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 FreeBSD 主機缺少一個或多個安全性相關更新。

描述

OpenSSL 團隊報告:

已修正 OpenSSL 1.0.0e 中的兩個安全性瑕疵

在某些情況下,OpenSSL 的內部憑證驗證常式可錯誤接受其 nextUpdate 欄位為過去的 CRL。(CVE-2011-3207)

暫時 ECDH 加密套件的 OpenSSL 伺服器程式碼執行緒不安全,此外,若用戶端以錯誤順序傳送交握訊息而違反通訊協定,其便可因而損毀。
(CVE-2011-3210)

解決方案

更新受影響的套件。

另請參閱

https://www.openssl.org/news/secadv/20110906.txt

http://www.nessus.org/u?b3f89c7e

Plugin 詳細資訊

嚴重性: Medium

ID: 56117

檔案名稱: freebsd_pkg_2ecb7b20d97e11e0b2e200215c6a37bb.nasl

版本: 1.15

類型: local

已發布: 2011/9/8

已更新: 2021/1/6

相依性: ssh_get_info.nasl

風險資訊

VPR

風險因素: Low

分數: 3.6

CVSS v2

風險因素: Medium

基本分數: 5

媒介: AV:N/AC:L/Au:N/C:N/I:P/A:N

弱點資訊

CPE: p-cpe:/a:freebsd:freebsd:linux-f10-openssl, p-cpe:/a:freebsd:freebsd:openssl, cpe:/o:freebsd:freebsd

必要的 KB 項目: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

修補程式發佈日期: 2011/9/7

弱點發布日期: 2011/9/6

參考資訊

CVE: CVE-2011-3207, CVE-2011-3210