PHP 5.3 < 5.3.7 多個弱點

critical Nessus Plugin ID 55925

Synopsis

遠端 Web 伺服器使用受到多個弱點影響的 PHP 版本。

描述

根據其標題,遠端主機上執行的 PHP 5.3.x 版本比 5.3.7 舊。因此受到以下弱點影響:

- substr_replace() 中有一個釋放後使用弱點。
(CVE-2011-1148)

- socket_connect() 的堆疊式緩衝區溢位。
(CVE-2011-1938)

- ZipArchive::addGlob() 中的程式碼執行弱點。
(CVE-2011-1657)

- crypt_blowfish 已更新至 1.2 版。(CVE-2011-2483)

- 多個 NULL 指標解除參照。(CVE-2011-3182)

- error_log() 中的不明損毀。(CVE-2011-3267)

- crypt() 中的緩衝區溢位。(CVE-2011-3268)

- 當將 MCRYPT_DEV_URANDOM 作為來源傳遞至 mcrypt_create_iv() 時,php_win32_get_random_bytes() 函式中存有一個瑕疵。遠端攻擊者可加以惡意利用,進而引發拒絕服務的情況。(OSVDB 126477)

解決方案

請升級至 PHP 5.3.7 或更新版本。

另請參閱

http://securityreason.com/achievement_securityalert/101

http://securityreason.com/exploitalert/10738

https://bugs.php.net/bug.php?id=54238

https://bugs.php.net/bug.php?id=54681

https://bugs.php.net/bug.php?id=54939

http://www.php.net/releases/5_3_7.php

Plugin 詳細資訊

嚴重性: Critical

ID: 55925

檔案名稱: php_5_3_7.nasl

版本: 1.21

類型: remote

系列: CGI abuses

已發布: 2011/8/22

已更新: 2022/4/11

組態: 啟用徹底檢查

風險資訊

VPR

風險因素: Medium

分數: 6.1

CVSS v2

風險因素: Critical

基本分數: 10

時間分數: 7.8

媒介: AV:N/AC:L/Au:N/C:C/I:C/A:C

時間媒介: E:POC/RL:OF/RC:C

CVSS 評分資料來源: CVE-2011-3268

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可輕鬆利用: No exploit is required

修補程式發佈日期: 2011/8/18

弱點發布日期: 2011/3/13

參考資訊

CVE: CVE-2011-1148, CVE-2011-1657, CVE-2011-1938, CVE-2011-2202, CVE-2011-2483, CVE-2011-3182, CVE-2011-3267, CVE-2011-3268

BID: 46843, 47950, 48259, 49241, 49249, 49252

EDB-ID: 17318, 17486