Mandriva Linux 安全性公告:ruby (MDVSA-2011:097)

medium Nessus Plugin ID 54626

Synopsis

遠端 Mandriva Linux 主機缺少一或多個安全性更新。

描述

在 ruby 中發現多個弱點且已修正:

在 Ruby 的 WEBrick HTTP 伺服器中,跨網站指令碼 (XSS) 弱點允許遠端攻擊者透過特製 URI 觸發 UTF-7 錯誤頁面,藉此插入任意 Web 指令碼或 HTML (CVE-2010-0541)。

Ruby 中的 FileUtils.remove_entry_secure 方法允許本機使用者透過符號連結攻擊刪除任意檔案 (CVE-2011-1004)。

Ruby 中的安全層級功能允許內容相依的攻擊者透過 Exception#to_s 方法修改字串,變更預定的路徑名稱即為一例 (CVE-2011-1005)。

在 Ruby 的 BigDecimal 類別中,bigdecimal.c 的 VpMemAlloc 函式未正確配置記憶體,這會允許內容相依的攻擊者透過與建立 64 位元處理程序內極大 BigDecimal 值有關的向量,執行任意程式碼或造成拒絕服務 (應用程式損毀);此弱點與整數截斷問題相關。(CVE-2011-0188)。

適用於 2009.0 的套件會隨著「延長維護計畫」提供。如需深入瞭解,請造訪這個連結:
http://store.mandriva.com/product_info.php?cPath=149 products_id=490

已修補更新版套件,以更正此問題。

解決方案

更新受影響的套件。

Plugin 詳細資訊

嚴重性: Medium

ID: 54626

檔案名稱: mandriva_MDVSA-2011-097.nasl

版本: 1.10

類型: local

已發布: 2011/5/24

已更新: 2021/1/6

風險資訊

VPR

風險因素: Medium

分數: 5.8

CVSS v2

風險因素: Medium

基本分數: 6.8

時間分數: 5.9

媒介: AV:N/AC:M/Au:N/C:P/I:P/A:P

時間媒介: E:ND/RL:OF/RC:C

弱點資訊

CPE: p-cpe:/a:mandriva:linux:ruby, p-cpe:/a:mandriva:linux:ruby-devel, p-cpe:/a:mandriva:linux:ruby-doc, p-cpe:/a:mandriva:linux:ruby-tk, cpe:/o:mandriva:linux:2009.0, cpe:/o:mandriva:linux:2010.1

必要的 KB 項目: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2011/5/23

參考資訊

CVE: CVE-2010-0541, CVE-2011-0188, CVE-2011-1004, CVE-2011-1005

BID: 40895, 46458, 46460, 46966

MDVSA: 2011:097