Debian DSA-2237-1:apr - 拒絕服務

medium Nessus Plugin ID 53900
新推出!弱點優先順序評分 (VPR)

Tenable 會為每個弱點計算動態 VPR。VPR 將弱點資訊與威脅情報和機器學習演算法加以結合,藉此預測攻擊者最有可能利用哪些弱點發動攻擊。查看詳細資訊: VPR 是什麼?它跟 CVSS 有何不同?

VPR 評分: 2.2

Synopsis

遠端 Debian 主機缺少安全性更新。

描述

在 APR 程式庫中發現一個瑕疵,其可透過 Apache HTTPD 的 mod_autoindex 遭到惡意利用。如果 mod_autoindex 編製索引的目錄包含名稱足夠長的檔案,遠端攻擊者可傳送特製的要求,進而造成 CPU 使用率過高。這一點可遭到惡意利用來發動拒絕服務攻擊。

解決方案

升級 apr 套件並重新啟動 apache2 伺服器。

針對舊的穩定發行版本 (lenny),此問題已在 1.2.12-5+lenny3 版中修正。

針對穩定的發行版本 (squeeze),此問題已在 1.4.2-6+squeeze1 版中修正。

另請參閱

https://packages.debian.org/source/squeeze/apr

https://www.debian.org/security/2011/dsa-2237

Plugin 詳細資訊

嚴重性: Medium

ID: 53900

檔案名稱: debian_DSA-2237.nasl

版本: 1.22

類型: local

代理程式: unix

已發布: 2011/5/16

已更新: 2021/1/4

相依性: ssh_get_info.nasl

風險資訊

風險因素: Medium

VPR 評分: 2.2

CVSS v2.0

基本分數: 4.3

時間分數: 3.4

媒介: AV:N/AC:M/Au:N/C:N/I:N/A:P

時間媒介: E:POC/RL:OF/RC:C

弱點資訊

CPE: p-cpe:/a:debian:debian_linux:apr, cpe:/o:debian:debian_linux:5.0, cpe:/o:debian:debian_linux:6.0

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2011/5/15

參考資訊

CVE: CVE-2011-0419

BID: 47820, 47929

DSA: 2237