Apache 2.2.x < 2.2.18 APR apr_fnmatch DoS

medium Nessus Plugin ID 53896
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 web 伺服器可能受到拒絕服務弱點的影響。

描述

根據其標題,遠端主機上執行的 Apache 2.2.x 版本比 2.2.18 舊。因此會受到一個拒絕服務弱點影響,該弱點是因為隨附 APR 程式庫之 apr_fnmatch() 函式中的錯誤所導致。

如果啟用 mod_autoindex,而且已編製含有長檔案名稱檔案的目錄索引,則攻擊者可能會因為特製的要求而造成高 CPU 使用率。

請注意,遠端 Web 伺服器可能實際上並不會受此弱點影響。Nessus 並未嘗試判定受影響的模組是否正在使用中,也未嘗試檢查問題本身。

解決方案

升級至 Apache 2.2.18 或更新版本。或者,確保 'IndexOptions' 組態選項已設為 'IgnoreClient'。

另請參閱

https://archive.apache.org/dist/httpd/CHANGES_2.2.18

http://httpd.apache.org/security/vulnerabilities_22.html#2.2.18

http://securityreason.com/achievement_securityalert/98

Plugin 詳細資訊

嚴重性: Medium

ID: 53896

檔案名稱: apache_2_2_18.nasl

版本: 1.20

類型: remote

系列: Web Servers

已發布: 2011/5/13

已更新: 2018/6/29

相依性: apache_http_version.nasl

風險資訊

VPR

風險因素: Low

分數: 2.2

CVSS v2

風險因素: Medium

基本分數: 4.3

時間分數: 3.4

媒介: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

時間媒介: CVSS2#E:POC/RL:OF/RC:C

CVSS v3

風險因素: Medium

基本分數: 5.3

時間分數: 4.8

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

時間媒介: CVSS:3.0/E:P/RL:O/RC:C

弱點資訊

CPE: cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*

必要的 KB 項目: installed_sw/Apache

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2011/5/12

弱點發布日期: 2011/5/10

參考資訊

CVE: CVE-2011-0419

BID: 47820

Secunia: 44574