CentOS 5 : python (CESA-2011:0492)

medium Nessus Plugin ID 53815
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 CentOS 主機缺少一個或多個安全性更新。

描述

現已提供適用於 Red Hat Enterprise Linux 5 的更新版 python 套件,可修正多個安全性問題。

Red Hat 安全性回應團隊已將此更新評等為具有中等安全性影響。可針對每個弱點從〈參照〉一節的 CVE 連結中取得常見弱點評分系統 (CVSS) 的基本分數,其中包含有關嚴重性評等的詳細資訊。

Python 是經過解譯的互動式物件導向程式設計語言。

Python urllib 和 urllib2 程式庫中發現一個瑕疵,兩者在處理自動化重新導向時,無法區分不同的目標 URL。這會造成使用這些模組的 Python 應用程式造訪其已知的任何新 URL,包括 'file://' URL 類型。這可讓遠端伺服器強制本機 Python 應用程式讀取本機檔案,而非遠端檔案,因而可能造成不應洩漏的本機檔案外洩。
(CVE-2011-1521)

Python smtpd 模組處理新連線時出現爭用情形。遠端使用者可利用此瑕疵,造成使用 smtpd 模組的 Python 指令碼終止。(CVE-2010-3493)

Python CGIHTTPServer 模組處理特定 HTTP GET 要求時,出現資訊洩漏的瑕疵。遠端攻擊者可利用特製的要求來取得 CGI 指令碼的原始程式碼。(CVE-2011-1015)

處理 XML 檔案時,在 Python Expat 剖析器處理格式有誤的 UTF-8 序列的方法中發現緩衝區過度讀取瑕疵。特製的 XML 檔案可造成利用 Python Expat 剖析器的 Python 應用程式在剖析檔案時當機。(CVE-2009-3720)

此更新會讓 Python 使用系統 Expat 程式庫,而非本身的內部複本。因此,使用者必須安裝 RHSA-2009:1625 隨附的 Expat 版本或更新版本,藉此解決 CVE-2009-3720 問題。

建議所有 Python 使用者皆升級至這些更新版套件,更新套件含有可更正這些問題的反向移植修補程式。

解決方案

更新受影響的 python 套件。

另請參閱

http://www.nessus.org/u?e31c929d

http://www.nessus.org/u?68bb9ae5

Plugin 詳細資訊

嚴重性: Medium

ID: 53815

檔案名稱: centos_RHSA-2011-0492.nasl

版本: 1.13

類型: local

代理程式: unix

已發布: 2011/5/6

已更新: 2021/1/4

相依性: ssh_get_info.nasl

風險資訊

VPR

風險因素: Medium

分數: 5.2

CVSS v2

風險因素: Medium

基本分數: 6.4

時間分數: 4.7

媒介: AV:N/AC:L/Au:N/C:P/I:N/A:P

時間媒介: E:U/RL:OF/RC:C

弱點資訊

CPE: p-cpe:/a:centos:centos:python, p-cpe:/a:centos:centos:python-devel, p-cpe:/a:centos:centos:python-libs, p-cpe:/a:centos:centos:python-tools, p-cpe:/a:centos:centos:tkinter, cpe:/o:centos:centos:5

必要的 KB 項目: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2011/5/5

弱點發布日期: 2009/11/3

參考資訊

CVE: CVE-2009-3720, CVE-2010-3493, CVE-2011-1015, CVE-2011-1521

BID: 36097, 44533, 46541, 47024

RHSA: 2011:0492